BASE Postgresql

BASE-user
luchika
2006-12-18
2013-06-03
  • luchika
    luchika
    2006-12-18

    I want to use postgresql for snort and BASE as GUI for alerts.
    I tried to set the BASE and after the 3-rd step: I got a blank page...I suppose that BASE tries to connect to DB to check the settings(DB-name, psw and so on), but I didn't get any error messages.

    I suppose BASE supports postgresql, but what can I do to get it working?

    thanks in advance

     
    • Kevin Johnson
      Kevin Johnson
      2006-12-19

      Did you get an error in your http logs?  Also could you give us some information on your set up?  For example, versions of BASE, DB, OS and web server types?

      Thanks
      Kevin

       
    • luchika
      luchika
      2006-12-20

      Hallo!

      My Configuration:
      BASE-1.2.7
      DB-Postgresql 8.1.3-12
      SUSE Linux 10.1
      PHP-5.2.0 (configured to support psql)

      and in error_log I get:

      [Wed Dec 20 10:58:17 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
      [Wed Dec 20 10:58:18 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
      [Wed Dec 20 10:58:19 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
      [Wed Dec 20 10:59:08 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
      [Wed Dec 20 10:59:11 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
      [Wed Dec 20 10:59:16 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
      [Wed Dec 20 10:59:16 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
      [Wed Dec 20 10:59:35 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'
      [Wed Dec 20 10:59:46 2006] [error] [client ::1] PHP Fatal error:  Call to undefined function pg_connect() in /srv/www/adodb/drivers/adodb-postgres64.inc.php on line 478, referer: http://localhost/base-1.2.7/setup/setup2.php?action=check
      [Wed Dec 20 10:59:46 2006] [error] Failed to change_hat to 'HANDLING_UNTRUSTED_INPUT'

      Thanks for any help
      Elena

       
      • Kevin Johnson
        Kevin Johnson
        2006-12-20

        Hi-

        I am not sure what the change_hat message is, maybe from AppArmor?  But the pg_connect error is saying that your copy of PHP does not have Postgres support.  You will need to install that.

        Kevin

         
      • Gary Evans
        Gary Evans
        2007-03-22

        I'm using SUSE 10, mysql. php5 and apache2 and I got the Same error message until I started AppArmor Event Notification  and reporting.

         
    • luchika
      luchika
      2006-12-20

      hi!

      thanks a lot!!!

      After you asked for information from error logs: I have understood, that smth. was wrong with the php recompilation: and after some attempts I have got it running!!! the problem was in php compilation.
      Now I have it working!

      warm regards
      elena