Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

BASE 1.4.2 and 1.4.3.1 Fatal Error

BASE-user
Jorge Lara
2009-07-26
2013-06-03
  • Jorge Lara
    Jorge Lara
    2009-07-26

    Greetings,

    I have tried to find information online on this error but I can't seem to come across anything helpful.

    I am using BASE 1.4.2, PHP 5.3.0, Apache 2.2.11 on a CentOS 5.3 Linux.

    I am able to run BASE of the Website, I am also able to login with the credentials I supplied during setup, and once I am in the main page I am able to read information off the MySQL Database I am using.  However, whenever I try to use any of the sorting options or use any of the links I am receiving the following error:

    Fatal error: Call to undefined method ProtocolFieldCriteria::ProtocolFieldCriteria() in /usr/local/apache2/htdocs/base-1.4.2/includes/base_state_citems.inc.php on line 1114

    I also tried with BASE 1.4.3.1 and got the same exact error only on line 1113.

    I am in DESPERATE need of a solution for this problem and I was wondering if you guys have any pointers on how to solve it.

    I will greatly appreciate any help I can get.

    Thank you very much.

     
    • Hello Jorge,

      quite strange, I must say. On fedora 11 with php 5.2.9 it works as it should.
      The first thing I would like you to check is, whether your file includes/base_state_citems.inc.php really looks like this:

      (...)
      1112
      1113       parent::ProtocolFieldCriteria($tdb, $cs, $export_name, $element_cnt,
      1114                                     array("ip_tos"  => "TOS",
      (...)

      If so, then the heritage mechanism on your box does not work as it did in the past. Could this be something new with php-5.3? Don't know, right now.

      Well, what happens when you change that line 1113

      from

      parent::ProtocolFieldCriteria(...)

      to either:

      parent::MultipleElementCriteria(...)

      or:

      MultipleElementCriteria::MultipleElementCriteria(...)

      Leave the argument list in both cases as it is.

      Bye, bye

      Juergen

      BTW: The whole file, as it is currently in CVS, can be viewed here:

      http://secureideas.cvs.sourceforge.net/viewvc/secureideas/base-php4/includes/base_state_citems.inc.php?view=markup

       
  • sophomERIC
    sophomERIC
    2009-10-29

    I had the same problem after I updated to PHP 5.3.0. I'm just posting to confirm that your fix works.

    sed -i 's%parent::ProtocolFieldCriteria%parent::MultipleElementCriteria%' base_state_citems.inc.php

    All better, thank you.