Errors in some pages

BASE-user
cih
2005-01-20
2013-06-03
  • cih
    cih
    2005-01-20

    Hi there!

    Well, i don't know why are happening these errors. I'm using BASE in RH 7.2, with PHP 5.0.3 and Apache 1.3.33. Since yesterday I'm having problems with an action in BASE. I read in many places that PHP 5 is supported by BASE, but yesterday I installed PHP 5.0.3 (i was working with PHP 4.1 branch before yesterday). The error i get:

    When I follow Search link in main page, I get something like this:

    Fatal error: Cannot use string offset as an array in /var/www/html/base/includes/base_state_citems.inc.php on line 731

    Anyone having same problems? Any point on how to get it working again? For me is very important to get back working with that search page ...

    Thanks in advance, and sorry for my bad english.

    P.S.: Thanks all developement team for let us enjoy this piece of soft again!

     
    • Kevin Johnson
      Kevin Johnson
      2005-01-20

      Thanks for the report.  The development team is looking into this and will try to get you an answer as soon as possible.

      Thanks
      Kevin

       
      • EdD
        EdD
        2005-01-20

        No problem!

        One more thing,  I also had to set

        $BASE_urlpath = "/machine2/base";

        in order for stylesheets and Home/Search/... links to work. Otherwise BASE would look a bit uncomplete... ;)

        Let me say one more thing: BASE is a great step forward and a good piece of work. Keep rockin' guys... :)

         
        • EdD
          EdD
          2005-01-20

          Ooops, wrong thread, sorry...

           
    • cih
      cih
      2005-01-20

      Thanks Kevin!

      Well, I found another thing that may be interesting for all ...

      I loose some info doing "Archive alerts (move)" to a previous created archive DB. For 45000 alerts I loose sig_class_id, and sig_priority. Yes I know, I must have done a backup before doing these sort of things ... bad luck!

      In new DB, table acid_event has been exported with NULL sig_class_id and sig_priority fields. Don't know what did happen with these, but hope nobody else has experimented on this before. My boss is still shouting! Yuck!

      Thanks for all your effort.

       
      • Kevin Johnson
        Kevin Johnson
        2005-01-24

        Hi-

        I have not heard this particular one before.  We do have reports of problems with archiving and are looking into them.

        Kevin

         
    • Kevin Johnson
      Kevin Johnson
      2005-01-23

      Hi-

      Tim Rupp, one of the developers has checked in a fix for the error:

      Fatal error: Cannot use string offset as an array in /var/www/html/base/includes/base_state_citems.inc.php on line 731

      Either you can get it from CVS or it will be part of the next release.

      Kevin
      Project Lead

       
    • cih
      cih
      2005-01-24

      Hi Kevin,

      that sounds great!
      Would implement changes in a moment.

      Anybody else has found the same problem archiving alerts? It's hard to believe i'm the only one who suffered that extrange behaviour.

      TIA

       
    • cih
      cih
      2005-01-24

      Hi,

      thanks for your input. would wait for the resolution of the problems you mention to try again archiving.

      Thanks for all your effort.