Right-click not blocked

SEB 2.0
2014-03-18
2014-03-20
  • Phil Butcher
    Phil Butcher
    2014-03-18

    The documentation says 'In the browser window there is no right mouse (or Shift+F10) click popup window available' but our trial users (Windows 2.0 RC4 + Moodle)were able to do this, and the knowledgeable ones selected 'insert an image' and set about enabling a new browser window.

     
  • Strange, I never saw the right click working in SEB. You didn't change the default setting for "Enable Right Mouse" I guess?

    Shift+F10 also didn't had an effect in my VM, will try it on physical machines tomorrow too.

     
  • Tim Hunt
    Tim Hunt
    2014-03-19

    This one might be to do with the Moodle HTML editor. That is, when a studnet is answering an Essay question in Moodle.

    So, I guess it comes down to what is being blocked. Is it mouse right click, or is it the browser's context menu.

     
  • Ok, I understood the problem now (and tried it out myself in Moodle). Looks like SEB only blocks the browser's context menu, not the right click itself. This surprises me, I thought it would block the right mouse button, but I will investigate this in the code.

    On the other side it would surely sometimes make sense to allow context menus of web applications, in some cases the functions there may be important to access. So I guess the best solution will be the URL web filter which we specified already (in settings and the configuration tool/preferences window) but its function isn't implemented yet and should follow in one of the next SEB 2.x versions.

     
  • Phil Butcher
    Phil Butcher
    2014-03-20

    This is now solved ;~)

    Alex put us onto the solution. Thank you.

    Happily you don't have to alter the .php file but can use the Custom settings for tinyMCE which are here admin/settings.php?section=editorsettingstinymce

    This is a system wide change but for us that's OK as we have a separate server for online exams.

    In the custom settings we have removed 'contextmenu,'.
    In that same field we have also set 'gecko_spellcheck": "false"' which stops the spell checking (one of my other posts).
    We have also removed 'iespell'. Because it had 'spell' in the name!
    And somewhere along the line these have also stopped Ctrl-F.

    FYI Moodle are working on a new editor. Tim Hunt has flagged what we've been doing with tinnyMCE here https://moodle.org/mod/forum/discuss.php?d=256538 to ensure that any new editor can still be configured as we require.

     
  • Phil Butcher
    Phil Butcher
    2014-03-20

    Further to my previous post other Moodle users might like to know that entering this

    {"plugins": "lists,table,style,layer,advhr,advlink,emotions,inlinepopups,paste,directionality,nonbreaking,save,preview,noneditable,visualchars,xhtmlxtras,template,pagebreak", "gecko_spellcheck": "false"}

    into the tinyMCE Custom settings field worked for us. We're on 2.5.
    The above
    - stops right-click - because 'contextmenu,' is excluded from the above list.
    - stops Ctrl-F - because 'searchreplace,' is excluded from the above list. Note that this is different from hiding 'searchreplace' in the editor toolbar.
    - stops automatic spellchecking.

    Tim Hunt offers advice and a warning here https://moodle.org/mod/forum/discuss.php?d=217965#p1113046.

     
  • Phil Butcher
    Phil Butcher
    2014-03-20

    Correction to the JSON above
    "gecko_spellcheck": "false"
    should read
    "gecko_spellcheck": false