#17 SEB not connecting to Moodle

closed-accepted
nobody
None
1
2012-02-02
2011-11-03
Delly
No

I am testing SEB 1.7 on Windows 7, using localhost/xampp. I downloaded the software and installed it successfully but when it loads, all I see are enabled applications( calc & notepad) and a blue window with an alert saying" The connection was refused when trying to contact www.safeexambrowser.org"

In the file, I have chenged the EXAM- URL to //localhost/moodle. And the exam I created in Moodle is set to be accessed via SEB

Someone, please tell me what else I have to do to be able to use SEB.
Thank you

Discussion

  • Dirk Bauer
    Dirk Bauer
    2011-11-03

    Hello, this sounds strange. You set URL_EXAM=//localhost/moodle but SEB tried to connect to www.safeexambrowser.org? Please post the complete SebStarter.ini file and MsgHook.ini file, for I can check and test it myself. I assume that the URL_EXAM is not correctly set.

     
  • Delly
    Delly
    2011-11-03

     
    Attachments
  • Delly
    Delly
    2011-11-03

     
    Attachments
  • Delly
    Delly
    2011-11-03

    Thanks alot for the reply. Attached are the 2 files

     
  • Dirk Bauer
    Dirk Bauer
    2011-11-03

    Hi, to me it has nothing to do with SEB because the line URL_EXAM=http://localhost/moodle seems to be correct. The problem seems to be reaching the localhost. I got the same error message when entering http://localhost/moodle directly into a separate Firefox browser, outside of SEB. Did you try that too? I have no Moodle on my machine but it seems to be a problem reaching "localhost". Maybe you could also replace "localhost" by "127.0.0.1", but please first try outside of SEB if the URL works.

     
  • Delly
    Delly
    2011-11-03

    Thnx again for your support! You were actually right, it wasn't connecting and it made me realise my mistake...I had downloaded and installed before changing the URL to localhost/moodle, so the changes to the file were not reflected anywhere. Now it is working perfectly....

     
  • Dirk Bauer
    Dirk Bauer
    2011-11-03

    Ah, I understand. Normally you should configure the .ini files before calling the SebWindowsInstall.msi, for the changed ini files are then copied to the Windows system, usually in C:\ProgramData\ETH Zuerich\SEB Windows 1.7\ . However, as an administrator, you can make a copy of SebStarter.ini in this ProgramData directory, modifiy the SebStarter.ini, delete the old SebStarter.ini and replace it by the new one (all in the ProgramData directory). So it is possible to change the settings even after installation. You are welcome.

     

  • Anonymous
    2011-11-30

    Hi,

    I am here again, with almost the same problem. Would you know why SEB cant connect to our e-learning site and I have specified the URL (http://www.elearning.strathmore.edu) in SebStarter.ini correctly?

    Or is there anything else I need to do?

     
  • Dirk Bauer
    Dirk Bauer
    2011-11-30

    Hi,

    probably you ran the SebWindowsInstall.msi file, installed SEB 1.7 and then afterwards changed the URL_EXAM in SebStarter.ini in the unpacked seb_1.7_win directory?

    You must edit the SebStarter.ini and MsgHook.ini _prior_ to calling the installer SebWindowsInstall.msi, because the installer will copy the modified .ini files to C:\ProgramData\ETH Zuerich\SEB Windows 1.7 .

    So you must uninstall SEB 1.7 first (using "Control Panel - Add/Remove Programs") or you must copy your modified SebStarter.ini into your ProgramData directory, overwriting the SebStarter.ini lying there (which is just a default one, therefore it tried to connect to the default URL www.safeexambrowser.org rather to your //localhost/moodle site).

    Regards, Dirk

     

  • Anonymous
    2011-11-30

    Thank you for the reply.

    I have done that but still it would not connect. Maybe you could try the url and see (http://www.elearning.strathmore.edu)

    I was wondering whether I have to install SEB in the school server where moodle is stored?

     
  • Dirk Bauer
    Dirk Bauer
    2011-11-30

    In my envirionment, http://www.elearning.strathmore.edu works!
    To avoid hunting for a phantom, it would be best if you sent me your
    complete SebStarter.ini and MsgHook.ini (by e-mail as attachment) or plane here.
    Also, which version exactly do you use? 1.5, 1.5.1, 1.6, 1.6.1, 1.7 or 1.7.1 ?

     

  • Anonymous
    2011-11-30

    MsgHook
    DISABLE_CTRL_ESC=0
    DISABLE_ALT_TAB=0
    DISABLE_ALT_ESC=0
    DISABLE_ALT_F4=1
    DISABLE_START_MENU=1
    DISABLE_RIGHT_MOUSE=1
    DISABLE_F1=1
    DISABLE_F2=1
    DISABLE_F3=1
    DISABLE_F4=1
    DISABLE_F5=1
    DISABLE_F6=1
    DISABLE_F7=1
    DISABLE_F8=1
    DISABLE_F9=1
    DISABLE_F10=1
    DISABLE_F11=1
    DISABLE_F12=1
    DISABLE_ESCAPE=1
    B1=114
    B2=122
    B3=117
    LOG_FILE=1
    KILL_CALLER_HOTKEY=Safe Exam Browser 1.7

    SebStarter
    [SEB]
    HOOK_DLL=MsgHook.dll
    MESSAGE_HOOK=1
    EDIT_REGISTRY=1
    FORCE_WINDOWS_SERVICE=1
    ALLOW_VIRTUAL_MACHINE=0
    REG_HIDE_FAST_USER_SWITCHING=1
    REG_DISABLE_LOCK_WORKSTATION=1
    REG_DISABLE_TASKMGR=1
    REG_DISABLE_CHANGE_PASSWORD=1
    REG_NO_CLOSE=1
    REG_NO_LOGOFF=1
    REG_ENABLE_SHADE=0
    REG_ENABLE_EASE_OF_ACCESS=0
    WIN9X_KILL_EXPLORER=1
    WIN9X_SCREENSAVERRUNNING=0
    NEW_DESKTOP=1
    SHOW_SEB_APP_CHOOSER=1
    STRONG_KILL_PROCESSES_BEFORE=
    STRONG_KILL_PROCESSES_AFTER=
    PERMITTED_APPS=Calculator,calc.exe;Notepad,notepad.exe;
    SEB_BROWSER=Seb,../xulrunner/xulrunner.exe ../xul_seb/application.ini
    AUTOSTART_PROCESS=Seb
    SHUTDOWN_AFTER_AUTOSTART_PROCESS_TERMINATES=0
    PROC_MONITORING=0
    LOG_FILE=1
    URL_EXAM=http://www.elearning.strathmore.edu/
    URL_EXAM=http://www.elearning.strathmore.edu/

     
  • Dirk Bauer
    Dirk Bauer
    2011-11-30

    As I expected, it was just a simple typo. In MsgHook.ini, you changed the last line from

    KILL_CALLER_HOTKEY=Safe Exam Browser 1.7

    to

    KILL_CALLER_HOTKEY=Safe Exam Browser 1.7

    But SEB expects three rather than one space before the version number 1.7.
    This string appears at the top of the application chooser window and may not be changed, otherwise SEB suspends (at least on my machine). So insert two spaces again, or just keep last line of the original MsgHook.ini file. (In future SEB versions, I plan to deliver a SebWindowsConfig tool with a mouse GUI which anyway prevents the user from accidentally editing lines which may not be changed).

    Does it work now?

     

  • Anonymous
    2011-11-30

    Sorry but it is not connecting...what is strange is that when I change back to http://localhost/moodle as url, it works!

     
  • Hi!

    Finally I got the solution...I had to change the prefs file in preferences to include our proxy settings and voila it works fine!

    Thanks a lot!

     
    • priority: 5 --> 1
    • status: open --> closed-accepted