#26 Search is not working

2.3
closed-fixed
nobody
None
9
2013-07-14
2013-01-08
Mirko
No

In current committed version the search features is not working.

Related

Bugs: #26

Discussion

  • Charles McCann
    Charles McCann
    2013-01-13

    I started to look into this defect. The defect appears to be happening because entries = null. It should have our list of values in it. In the FindNextDialog.update method, the entries variable is getting set twice by the observable pattern. First time, it contains data. Second time, is set to null.

    Any changes made that would have cleared the entries? However, they aren't gone permanently, because the reset of the app still works.

     
  • Mirko
    Mirko
    2013-03-08

    The problem is that the FindNextDialog is an Observer of EntryListener but when somethings changes it is non updated automatically.
    The collection of entries is empty and the search can't work.

     
  • Mirko
    Mirko
    2013-07-14

    • status: open --> closed-fixed
     
  • Charles McCann
    Charles McCann
    2013-07-14

    Looks like you figured out the bugs.  Awesome! 


    From: Mirko banzaay@users.sf.net
    To: [sdm:bugs] 26@bugs.sdm.p.re.sf.net
    Sent: Sunday, July 14, 2013 5:32 AM
    Subject: [sdm:bugs] #26 Search is not working

    * status: open --> closed-fixed
    

    [bugs:#26] Search is not working
    Status: closed-fixed
    Created: Tue Jan 08, 2013 03:53 PM UTC by Mirko
    Last Updated: Fri Mar 08, 2013 04:46 PM UTC
    Owner: nobody
    In current committed version the search features is not working.


    Sent from sourceforge.net because you indicated interest in https://sourceforge.net/p/sdm/bugs/26/
    To unsubscribe from further messages, please visit https://sourceforge.net/auth/subscriptions/

     

    Related

    Bugs: #26