#1962 NetBSD sparc64 ucz80 and ucz180 regtest failures

closed-fixed
z80 port (188)
7
2012-03-12
2012-03-10
Borut Ražem
No

ucz80 and ucz180 regression tests are failing on NetBSD sparc64 snapshot build machine.

I compared asm files generated on NetBSD sparc64 with ones generated on Linux x86_64 and found out that genAddrOf generates additional ex (sp), hl instruction, which is not present on Linux x86_64:

Linux x86_64:
; genAddrOf
ld hl,#_TestVar

NetBSD sparc64:
; genAddrOf
ld hl,#_TestVar
ex (sp), hl

Complete regtest gen directories for absolute regtest on both platforms is in attached absolute.tar.bz2 file.

Borut

Discussion

  • Borut Ražem
    Borut Ražem
    2012-03-10

     
    Attachments
  • commitPair() wrongly assumed an operand to be on the stack. Increasing priority, since wrong code was generated silently. Fixed in revision #7419.

    Philipp

     
    • priority: 5 --> 7
    • assigned_to: nobody --> spth
    • status: open --> closed-fixed
     
  • Hmm, there's still a lot of regression test failures. So it seems while one bug is fixed there are still some left.

    Philipp

     
    • status: closed-fixed --> closed-remind
     
  • Ok, todays snapshots show all these issues are fixed.

    Philipp

     
    • status: closed-remind --> closed-fixed