Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1892 stdarg problem

closed-fixed
z80 port (188)
7
2012-01-27
2011-12-21
No

support/regression/tests/gcc-torture-execute-stdarg-4.c fails on z80 and related ports in current svn (rev. #7115). To reproduce: Change the #if 0 in line 150 to #if 1.
Setting priority to 7 since bad code is being generated silently.

Philipp

Discussion

    • assigned_to: nobody --> spth
    • status: open --> closed-fixed
     
  • Fixed in sdcc revision #7151.

    Philipp

     
  • Sorry, I accidentially posted the "fixed" message to the wrong bug report.

     
    • assigned_to: spth --> nobody
    • status: closed-fixed --> open
     
  • It does not fail for all z80-related ports. It works for the gbz80.

    Philipp

     
    • assigned_to: nobody --> spth
    • status: open --> closed-fixed
     
  • Fixed in revision #7265.

    Philipp