#1621 Paste doesn't work if any web browser is running

Bug
closed-invalid
Neil Hodgson
1
2014-08-14
2014-07-11
Gordon Tyler
No

SciTE for AutoIT Version 3.4.1 Apr 28 2014 22:02:00.
If web browser is running (IE 11, Google Chrome, or Firefox) then the paste function (any method) will always paste an empty string.
Running on Windows 8.1 64-bit.
Did a full uninstall, registry clean, data file clean an fresh install and it doesn't help.

Discussion

  • Neil Hodgson
    Neil Hodgson
    2014-07-11

    This bug tracker is for standard SciTE, not SciTE for AutoIT which is a separate project. The paste command works fine for me with standard SciTE 3.4.4 on Windows 8.1 Pro. Can you download standard SciTE to check whether it also shows this problem:
    http://www.scintilla.org/SciTEDownload.html

     
  • Gordon Tyler
    Gordon Tyler
    2014-07-11

    I had the same problem with the standard SciTE version, but I finally found the true cause:
    My security software “Webroot SecureAnywhere” was blocking it.
    There must be some unique way in which you are accessing the clipboard.

    Here is the advanced option in SecureAnywhere that, once disabled, allows for pasting:
    Settings -> Shields
    “Silently and automatically block untrusted access to user data”

    Now, as soon as I click paste, it pops up a warning that I need to dismiss.
    Luckily, there is an option to trust the SciTE program so no more popups are shown.
    This happens even if I am pasting something from one part of the edited file to another.
    It does not block pasting the same information when running the Notepad application.

    Not sure if you want to redesign SciTE, but I have a work around for now.

     
  • Neil Hodgson
    Neil Hodgson
    2014-07-11

    • status: open --> open-invalid
    • assigned_to: Neil Hodgson
    • Priority: 5 --> 1
     
  • Neil Hodgson
    Neil Hodgson
    2014-07-11

    Scintilla/SciTE always use the global clipboard for copy and paste. Notepad may be using an in-process clipboard when it can. Changing the clipboard behaviour would be a lot of work so won't be done.

     
  • Gordon Tyler
    Gordon Tyler
    2014-07-11

    I will contact Webroot and let you know what their response is on the matter.

     
  • Gordon Tyler
    Gordon Tyler
    2014-07-12

    There is a large thread on their support web site about this problem with other applications. I am going to suggest them changing the default setting to not be silent, although some people are complaining the application white list will reset.

    Looks like the ball is in their court.

     
  • Neil Hodgson
    Neil Hodgson
    2014-08-14

    • status: open-invalid --> closed-invalid