Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1503 Scite opens infinite dialog boxes when trying to save a file

Bug
closed-fixed
Neil Hodgson
3
2013-08-31
2013-07-24
Slevin
No

This happens on two occasions: when trying to save to a directory with non ascii characters like the block character as seen in the image or when saving to a system folder or one that the user does not have ownership.
The dialog boxes kept popping up until the comp started to hang. I managed to close about 20 of them and kill scite with powershell.

Discussion

  • Slevin
    Slevin
    2013-07-24

    Image when saving to folder with non ascii path

     
    Attachments
  • Slevin
    Slevin
    2013-07-24

    the folder in explorer with the block drawing character in its path

     
    Attachments
  • Slevin
    Slevin
    2013-07-24

    inside that folder(sorry for posting images this way, there's no option for uploading multiple files.)

     
    Attachments
  • Slevin
    Slevin
    2013-07-24

    when editing a file in windows folder

     
  • Slevin
    Slevin
    2013-07-24

    the result. btw, i'm using version 3.2.5 and also have 3.3.1 but haven't tested it there. I think the results will be the same. I don't want to install it over the current one.

     
    Attachments
  • Neil Hodgson
    Neil Hodgson
    2013-07-24

    Can't reproduce with the path "C:\u\hg\pending\Encoding\██ Scite Pitfall ██\Scite can't touch me.txt" on Windows 7. The particular block drawing character may be important.

    For the Windows directory I see a warning about needing permission to save there.

     
    • Slevin
      Slevin
      2013-07-24

      What do you mean by important? To scite or explorer? Btw other editors like notepad can save there. Sooo... It's not a bug?

       
      • Neil Hodgson
        Neil Hodgson
        2013-07-24

        The '█' character you used may be different to the one I used and that difference may have caused the failure. You only showed pictures of the file name. Nowhere have you reported the file name as text so that it can be checked.

         
  • Slevin
    Slevin
    2013-07-25

    Run this.

    It will create a folder with the drawing character as part of its name

    and writes a file in it. Try to open in the folder in scite and you should

    get the 'infinite' dialog boxes.(Make sure you have task manager or powershell open ;)

    This is a list of the code points for the drawing characters which you can

    enter manually in windows using a key combination of ALT+219 or any other

    number in from 0 to 256

    [9500, 9508, 9516, 9524, 9532, 9552, 9553, 9554, 9555, 9556, 9557, 9558, 9559,
    9560, 9561, 9562, 9563, 9564, 9565, 9566, 9567, 9568, 9569, 9570, 9571, 9572,
    9573, 9574, 9575, 9576, 9577, 9578, 9579, 9580, 9600, 9604, 9608, 9612, 9616,
    9617, 9618, 9619]

    import os
    fname="Note the semigraph,"+unichr(9608)
    os.mkdir(fname)
    os.chdir(fname)
    open("dummy_file.txt","w").write("You won't see me in scite!!!!")

    The weird thing is that if you name your file with a U+9608 character or any other character on that list, scite will open the file( but won't show the original contents) and save it happily. It'll display the drawing character as a &brevbar; in the tabbar.

    Hope that helped.

     
  • Neil Hodgson
    Neil Hodgson
    2013-07-25

    Can't reproduce with SciTE 3.2.5 or 3.3.4 with an empty user properties and startup script.
    Path with a block

     
  • Neil Hodgson
    Neil Hodgson
    2013-07-25

    • labels: saving a file --> saving a file, scite
    • status: open --> open-works-for-me
    • assigned_to: Neil Hodgson
    • Priority: 9 --> 3
     
  • Slevin
    Slevin
    2013-07-25

    Hi, again. I found the cause of the problem. I had earlier installed a SciTE patch from a russian site http://scite.ruteam.ru/scite/sborki/scite-ru-board and installed Scite 3.2.5 over it. I only had to uninstall scite again and then install it again. I'm sure this time you'll get the same result. Although SciTe only displays the contents of the file when the file is dragged to it or opened from the menu. It still doesn't display the contents when I use the 'Open with Scite' option. At least it works.
    Hail SciTE!!!!

     
  • Neil Hodgson
    Neil Hodgson
    2013-07-26

    • status: open-works-for-me --> closed-works-for-me
     
  • Slevin
    Slevin
    2013-07-27

    Forget what I said earlier, I have really found the cause of the problem this time. Please try it.
    Reproduce:
    Uncomment the #save.on.timer=20 option then try to save a file that you do not have permissions(e.g the ones in system32) or the original dummy_file.txt(don't open it in scite or drag it, open it from the context menu in explorer). You should get the many dialogs. Give it a try, please.

     
  • Neil Hodgson
    Neil Hodgson
    2013-07-28

    • status: closed-works-for-me --> open-accepted
     
  • Neil Hodgson
    Neil Hodgson
    2013-07-31

    Fix committed as [b60463].

     

    Related

    Commit: [b60463]

  • Neil Hodgson
    Neil Hodgson
    2013-07-31

    • status: open-accepted --> open-fixed
     
  • Neil Hodgson
    Neil Hodgson
    2013-08-31

    • status: open-fixed --> closed-fixed