#1339 SciTE cannot save file

Bug
closed-fixed
Neil Hodgson
SciTE (619)
5
2013-09-10
2012-03-28
Pok
No

On Slackware 13.37 x86_64...

If I want to save a brand new file to my home folder I get the message "The file /home/<user>/Documents/<file name>" has not been loaded entirely, so it can not be saved right now. Please retry in a while.

This only happens with the default buffer. If the unsaved file is closed by issuing the "New" command (discarding it) than the new buffer can be saved OK in the same location. The amount of data that I am trying to save is a few characters. This happened with both 3.0.3 and 3.0.4.

Discussion

  • Neil Hodgson
    Neil Hodgson
    2012-03-28

    • assigned_to: nobody --> nyamatongwe
    • status: open --> open-works-for-me
     
  • Neil Hodgson
    Neil Hodgson
    2012-03-28

    This does not happen to me on Xubuntu 11.10 with the following steps:
    Start SciTE from command line.
    In the single Untitled buffer, type "#".
    Press Ctrl+S to save.
    Navigate to the home folder.
    Type "x.py" into the Name field and press the Save button.
    File is saved.
    There is a warning in the command line window about being unable to stat the file but that is just that SciTE is checking the modification time of the file if it already existed.

     
  • Pok
    Pok
    2012-11-19

    • status: open-works-for-me --> open-rejected
     
  • Pok
    Pok
    2012-11-19

    I have done some experiments and it seems that the problem occurs if you want to disable buffers.
    That is you set buffers property to less than 2.
    So, if I set the buffers property to 0 or 1 than you get the error when saving.
    If you set the buffers property to 2 or higher, you do not get the error anymore.

    I have re-tested with 3.2.0 on Windows XP and 3.2.2 on (Slackware) Linux (x86_64) with similar results.

     
  • Pok
    Pok
    2012-11-19

    • status: open-rejected --> open-remind
     
  • Neil Hodgson
    Neil Hodgson
    2013-01-07

    Committed change sets [2ca8a8] and [e3f9c5] which improve behaviour in this area for single buffer mode and when loading more documents than buffers.

     

    Related

    Commit: [2ca8a8]
    Commit: [e3f9c5]

  • Neil Hodgson
    Neil Hodgson
    2013-06-12

    • status: open-remind --> closed-out-of-date
     
  • Neil Hodgson
    Neil Hodgson
    2013-06-12

    No report since changes so closing.

     
  • Pok
    Pok
    2013-08-05

    Sorry about being late with the answer, but I have not had time to switch to the newest version till now.
    So I did some new testing and the problem is still there:
    set
    buffers=0
    Or
    buffers=1
    Close (all) SciTE (instances).
    Open it and write something in the editor.
    Try to save it and the error will pop up.
    If auto-saving kicks in, it also produces the error.
    set
    buffers=>2
    and the problems go away.
    The documentation does not state that 1 is not a valid value for buffers - on the contrary.
    The above only happens right after start-up, for the default buffer.
    If a file is opened, or the new menu item is activated, the error does not show up anymore.

    B.T.W. the documentation states that
    „This value is read only once, early in the startup process and only from the global properties files.”
    and that does not seem to be accurate: I did my testing changing the user options file.

    This has been tested and consistently reproduced on Windows 7 (x64) and SciTE (3.3.4, downloaded from the site) and on (Slackware64) Linux and SciTE (3.3.3 self-compiled).

     
  • Neil Hodgson
    Neil Hodgson
    2013-08-07

    • status: closed-out-of-date --> open-fixed
     
  • Neil Hodgson
    Neil Hodgson
    2013-08-07

    Fix committed as [3e1b0b].

    Documentation updated to mention user properties.

     

    Related

    Commit: [3e1b0b]

  • Neil Hodgson
    Neil Hodgson
    2013-08-31

    • status: open-fixed --> closed-fixed
     
  • Pok
    Pok
    2013-09-10

    Have just installed 3.3.5.
    Thanks for the fix! :-)