Hi,

   Thanks Samuel, -  I'm leaning towards your suggestion.  I actually solved this problem after many frustrating hours.  However, NEW install problems have appeared.

Here are some concrete suggestions for the developers for SciGraphica:

1) Provide detailed, clear installation instructions on the SciGraphica website.  Assume those implementing SciGraphica are not programmers, but scientists - take for example. myself.  I use UBUNTU because there are some scientific programmes (originally written for the human genome project) that require LINUX.  Ubuntu's philosophy is "it just works".  SciGraphica could learn from this philosophy.

2) PLEASE BUILD Debian (*.deb) and Fedora (*.rpm) installer packages of the latest builds.  Manually installing "by hand" is difficult and cumbersome.

3) Work with the major distros of Linux (Ubuntu, SuSE, Fedora) to make Scigraphica part of their upgrade/update functions.

I will continue to use the old 0.8.0 version that comes as part of the Ubuntu packages.  However, I will abandon attempts to use the new version (2.x).of SciGraphica until a Debian installer package is provided.

Good Luck,
Andor

On Thu, 2006-06-29 at 09:09 +0200, Samuel Verstraete wrote:
Hi Andor...

I seriously doubt if you wanna invest time in this... I have invested
time in getting SciGraphica to work... but it's so unstable that i have
to consider all of that time lost...

Do consider qtiplot instead for you scientific graphical plotting. The
maintainer responds to every question asked and fixes very quickly
stuff when you encounter problem...

(this is not to shoot SciGraphica in the back or anything but i'm just
making sure Andor doesn't waste time compiling programs that are
in a state that makes them unusable... Though i would be very glad if
the devs of this program could pickup their work again... )

gr,S.

On Wed, 28 Jun 2006 22:22:51 -0400
Andor J Kiss <andor@UDel.Edu> wrote:

> Yet again, another SciGraphica install error:
> 
> 
> 
> checking for GLIB - version >= 2.5.7...
> *** 'pkg-config --modversion glib-2.0' returned 2.8.6, but GLIB
> (2.10.3) *** was found! If pkg-config was correct, then it is best
> *** to remove the old version of GLib. You may also be able to fix the
> error
> *** by modifying your LD_LIBRARY_PATH enviroment variable, or by
> editing *** /etc/ld.so.conf. Make sure you have run ldconfig if that
> is *** required on your system.
> *** If pkg-config was wrong, set the environment variable
> PKG_CONFIG_PATH
> *** to point to the correct configuration files
> no
> checking for pkg-config... (cached) /usr/bin/pkg-config
> checking for GLIB - version >= 2.0.0...
> *** 'pkg-config --modversion glib-2.0' returned 2.8.6, but GLIB
> (2.10.3) *** was found! If pkg-config was correct, then it is best
> *** to remove the old version of GLib. You may also be able to fix the
> error
> *** by modifying your LD_LIBRARY_PATH enviroment variable, or by
> editing *** /etc/ld.so.conf. Make sure you have run ldconfig if that
> is *** required on your system.
> *** If pkg-config was wrong, set the environment variable
> PKG_CONFIG_PATH
> *** to point to the correct configuration files
> no
> configure: error:
> *** GLIB 2.0.0 or better is required. The latest version of
> *** GLIB is always available from ftp://ftp.gtk.org/. If GLIB is
> installed
> *** but not in the same location as pkg-config add the location of the
> file
> *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
> 
> Suggestions?
> 
> 
> 
> 


______________________________________________________________
Andor J Kiss
Department of Biological Sciences
29 East Delaware Avenue
University of Delaware
Newark, Delaware   19716
USA

eMAIL: andor@udel.edu
URL: http://www.udel.edu/bio/people/postdoc/akiss.html
______________________________________________________________
Andor J Kiss
Department of Biological Sciences
29 East Delaware Avenue
University of Delaware
Newark, Delaware   19716
USA

eMAIL: andor@udel.edu
URL: http://www.udel.edu/bio/people/postdoc/akiss.html