Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Problem with SISCweb

2007-04-03
2013-05-03
  • Marco Bakera
    Marco Bakera
    2007-04-03

    Recently I was trying to figure out how to use REPL support to develop with SISCweb. Unfortunately, I ran into some problems connecting the REPL.

    Whenever I try to connect to the REPL I got a 'Connection refused' error.

    Any suggestions what went wrong in my setup?

    I used Jetty as servlet container and the siscweb-examples warfile.

    Thanks for any kind of help.

    Greetings,
    Marco.

     
    • Marco,

      I tried to run the siscweb-examples with Jetty, and everything was fine. BUT the REPL was not accessible (connection refused). So, at least, I was able to reproduce your problem.

      (Note that I had to unpack the War file, and edit the web.xml file. You have to modify it to enable the embedded REPL.)

      I tried two other things:
      - run the same exact webapp in Tomcat 4.1. The REPL was accessible.
      - access the REPL using telnet. With Jetty, I got a connection refused.

      So my conclusion is that maybe Jetty prevents web applications from starting threads if they don't use the thread pooling mechanism (a limitation due to the old J2EE spec). The problem does not seem to be on the SchemeScript side. To be honest, I am not a Jetty expert. So either you ask for help on the siscweb mailing list or on the Jetty mailing list.

      Hope this helps,

      Dominique

       
    • Marco Bakera
      Marco Bakera
      2007-04-04

      Thanks for your help. I have just send my question out to the siscweb mailinglist. I supposed the problem originated from jetty but was a little confused whom to ask for this.

      So thanks for your help.

      Greetings,
      Marco.

       
    • Marco Bakera
      Marco Bakera
      2007-04-04

      Just to complete this thread and give an answer to my question I will post the answer that I got from Alessandro Colomba. Perhaps that might be helpful for someone else as well.

      alessandro Colomba  wrote:

      Marco,

      You're right. Jetty is not picking up the environment entries from
      JNDI. Which version of Jetty are you using?

      As I understand it, Jetty supports JNDI only starting from version 6,
      and even then you have to take extra steps, as documented in:

      http://docs.codehaus.org/display/JETTY/JNDI

      In short you have to:

      1) place the war files in webapps-plus,
      2) run Jetty with "java -jar start.jar etc/jetty.xml etc/jetty-plus.xml"

      This does the trick for me.

      It seems however that the continuation hash interferes with Jetty
      picking up the jsessionid path parameter, so you will see a glitch in
      SISCweb v0.4 even if you have cookies enabled. (It will take a couple
      of requests to get the examples rolling.)

      The glitch does not appear in SISCweb v0.5 (due for release within
      days), but you still need to keep cookies enabled. I'll see if I can
      fix this before releasing.

      Thank you for pointing me to Jetty. I had never had a chance to use it before.