I caused a regression in WITH-PACKAGE-ITERATOR. The new implementation can crash if UNINTERN is called on the current symbol, which is supposed to be permitted during package traversal.  I have a test case and will commit a fix today.