Hello Didier,

 There is the bug report on this:

https://bugs.launchpad.net/sbcl/+bug/338924

I am not sure about the exact match, but the issue seems to be related to what you have encountered.


Regards,
Roman


2010/6/14 Didier Verna <didier@lrde.epita.fr>

 Hi, two questions about getenv:

1/ should I use sb-posix:getenv or sb-ext:posix-getenv ?

2/ also, getenv seems to behave differently on Mac and on Linux
  (probably because of differences at a the OS level):

  (getenv nil) used to return nil which I kinda liked, but now on Linux
  (1.0.39.15, although I can't tell exactly when it started) it throws
  an error (see below). Is this intentional ? On my Mac on the other
  hand, with 1.0.39.9, it still returns nil.


Thanks a lot !


* (sb-ext:posix-getenv nil)
CORRUPTION WARNING in SBCL pid 13919(tid 3085067968):
Memory fault at 0 (pc=0xb7e9a561, sp=0xb78eeb4c)
The integrity of this image is possibly compromised.
Continuing with fingers crossed.

debugger invoked on a SB-SYS:MEMORY-FAULT-ERROR in thread #<THREAD
                                                           "initial thread" RUNNING
                                                           {A9F5AF1}>:
 Unhandled memory fault at #x0.

Type HELP for debugger help, or (SB-EXT:QUIT) to exit from SBCL.

restarts (invokable by number or by possibly-abbreviated name):
 0: [ABORT] Exit debugger, returning to top level.

(SB-SYS:MEMORY-FAULT-ERROR)
0] 0

--
Resistance is futile. You will be jazzimilated.

Scientific site:   http://www.lrde.epita.fr/~didier
Music (Jazz) site: http://www.didierverna.com

------------------------------------------------------------------------------
ThinkGeek and WIRED's GeekDad team up for the Ultimate
GeekDad Father's Day Giveaway. ONE MASSIVE PRIZE to the
lucky parental unit.  See the prize list and enter to win:
http://p.sf.net/sfu/thinkgeek-promo
_______________________________________________
Sbcl-help mailing list
Sbcl-help@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/sbcl-help