Hi Simon,
 
I've been unable to reproduce the href select issue using Saxon-CE alpha 0.4 and the details you provide. Please could you submit an html source file along with an xsl stylesheet that reproduces this behaviour - also, what version of Firefox/OS are you using?
 
Thanks
 
Phil

On Sun, Dec 11, 2011 at 12:04 PM, Simon Pepping @ Home <spepping@leverkruid.eu> wrote:

I upgraded to Saxon CE 0.4. Even so, the instruction
<xsl:result-document href="?select=//head" method="ixsl:append-content">
does not select a node in the HTML file, while
<xsl:result-document href="#head" method="ixsl:append-content">
does. The html file contains: <html><head id=#head>...

I can see that no node is selected, because the instruction should append
two link elements, which I can see in firebug in the latter case, but not in
the former. Moreover, one link element inserts a CSS stylesheet, whose
effect is immediately visible in the latter case, but no style changes are
seen in the former.

Thanks for this product and for the vision behind it. I love Wendell Piez's
demo of the possibilities (except that the link to it from the saxonica page
has been removed?).

Regards, Simon
--
View this message in context: http://old.nabble.com/href%3D%22-select%3D--head%22-does-not-select-a-node-in-Saxon-CE-0.4-tp32954899p32954899.html
Sent from the saxon-help mailing list archive at Nabble.com.


------------------------------------------------------------------------------
Learn Windows Azure Live!  Tuesday, Dec 13, 2011
Microsoft is holding a special Learn Windows Azure training event for
developers. It will provide a great way to learn Windows Azure and what it
provides. You can attend the event by watching it streamed LIVE online.
Learn more at http://p.sf.net/sfu/ms-windowsazure
_______________________________________________
saxon-help mailing list archived at http://saxon.markmail.org/
saxon-help@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/saxon-help