Hi - I'm just starting with saxon on a project that is going to invoke XQuery via XQJ in java programs.
 
My first go at this encounters this exception -
 
      java.lang.NoClassDefFoundError: javax.xml.stream.XMLStreamReader
 
This happens on an XExpression.bindString (...) call.
 
I see in the install instructions that I should expect saxon to work with Java 1.5.  I also see in archives of this list some discussion that Stax is bundled with Java 1.6 so you need to get another jar (woodstox preferably?) to use Stax before Java 1.6. Further there is some discussion doubting that Stax is much advantage over SAX for this application.  I did not do anything to request use of Stax.
 
Is Stax required for XQuery?  What should I do to resolve this exception?
 
Thanks - Paul Copeland