Could you confirm that you are using the latest version 9.2.1.1? There were some build problems with earlier releases of Saxon 9.2 on .NET, but 9.2.1.1 should be OK. (The problems with earlier builds were due to unresolved dependencies rather than absence of a strong name, so I'm not sure this explains the issue, but it's a good place to start.)
 
How did you attempt to install the assembly in the GAC?
 

Regards,

Michael Kay
http://www.saxonica.com/
http://twitter.com/michaelhkay



From: Christopher Szalaj [mailto:cszalaj@tpac.org]
Sent: 25 May 2010 21:48
To: 'saxon-help@lists.sourceforge.net'
Subject: [saxon] First Saxon xslt and config

I am new to using Saxon, and recently installed it. I tested the installation from the command line and it works great. When I try to add the API assembly (saxon9he-api.dll ) to the Global Assembly Cache it tells me that it cannot be added because it doesn’t have a Public  Key. When I look at the GAC, none of the assemblies appear in the list.  Is there something else I need to do to add the assemblies?

 

Also, is there somewhere you can point me for step-by-step instructions on building a .NET web app that uses Saxon for its xsl transforms?

 

Thanks,

Chris Szalaj