In my previous response I asked you to provide some evidence. The onus is on you to construct an example that shows the input and the incorrect output. I think it's very unlikely that there is a Saxon problem here: I'm prepared to keep an open mind, but I'm not prepared to construct test cases specially for you. Show a source document, a simple stylesheet, and a result document, and it will soon be clear whether you are making some elementary mistake or whether something very strange is happening.
 
Michael Kay


From: saxon-help-admin@lists.sourceforge.net [mailto:saxon-help-admin@lists.sourceforge.net] On Behalf Of Rik Jones
Sent: 14 March 2006 19:33
To: saxon-help@lists.sourceforge.net
Subject: RE: RE: [saxon] Can't remove line feeds with Saxon 6.5.3

This problem does not occur in my Widows .NET  XSLT parser so I think it may be SAXON specific.
 
Normalize space does not remove line feeds
 
 <xsl:variable name="name" select="@name"/>
 <xsl:variable name="value" select="normalize-space(/Root/Data/DataElement[@name = $name]/Value)" />

 
—------------------
Neither does translate
 
 <xsl:variable name="name" select="@name"/>
 <xsl:variable name="value" select="translate(/Root/Data/DataElement[@name = $name]/Value,'&#x9;&#xa;&#xd;','')"/>
 
So any ideas on how to remove line feeds in SAXON?
 
I am getting frustrated with this.
 
FYI:
I tried SAXON 6.5.5 same problem.
xsl-list at mulberrytech.com recomended using normalize-space(.)

 
 

Message: 1
From: "Michael Kay" <mike@saxonica.com>
To: <saxon-help@lists.sourceforge.net>
Subject: RE: [saxon] Can't remove line feeds with Saxon 6.5.3
Date: Sun, 12 Mar 2006 21:19:21 -0000
Reply-To: saxon-help@lists.sourceforge.net

I can't see from this sample what you are doing wrong. It would be useful to
post a complex stylesheet or query, cut down to show the essence of the
problem, and explain what output you are getting and what output you
expected. This will then reveal where you are making some incorrect
assumption.

In fact, though, this is probably not a Saxon-specific problem at all, but a
general XSLT coding enquiry. So, rather than asking on a product-specific
list, you should raise your question on the xsl-list at mulberrytech.com

Michael Kay
Saxonica


> -----Original Message-----
> From: saxon-help-admin@lists.sourceforge.net
> [mailto:saxon-help-admin@lists.sourceforge.net] On Behalf Of Rik Jones
> Sent: 11 March 2006 18:48
> To: saxon-help@lists.sourceforge.net
> Subject: [saxon] Can't remove line feeds with Saxon 6.5.3
>
> I can't get my code to work to remove line feeds with Saxon 6.5.3
>
> I am using the following code:
>
> normalize-space(translate($Value,'&#x9;&#xa;&#xd;',''))
>
> Any ideas would be helpful, I am relatively new to XSLT, and just
> started a project with Saxon. I did not pick the Saxon
> version that was,
> trust upon me.
>
>
>
>
>
> Rik Jones
> Internet/Intranet Project manager
>
 
Rik Jones
Internet/Intranet Project manager