Hi Andrew,
 
Thanks for the response, I appreciate it.
 
> You are missing the double quotes there...

Sorry, that was a copy & paste error.
 
> You might also want to check how it worked fine locally, as that would
> always cause an exception.

When I run the code locally (i.e. outside of an applet), I don't get any exceptions with the same XML & XSL files.
 
> Also, version 1.1 doesn't exist, you should change that to 2.0

I've just changed the version to 2.0 on a standalone module & then only thing that changed is the warning message from:
 
-----------------------------------------------------------------------------------------------------------------------------

Warning: Running an XSLT 1.0 stylesheet with an XSLT 2.0 processor

Aug 19, 2011 8:58:52 AM org.apache.fop.fo.FONode attributeWarning

WARNING: Warning(20/-1): fo:table, table-layout="auto" is currently not supported by FOP
-----------------------------------------------------------------------------------------------------------------------------
 
to:
 
-----------------------------------------------------------------------------------------------------------------------------
Aug 19, 2011 1:44:31 PM org.apache.fop.fo.FONode attributeWarning
WARNING: Warning(20/-1): fo:table, table-layout="auto" is currently not supported by FOP
-----------------------------------------------------------------------------------------------------------------------------
 
Regards,
Kamo

--- On Fri, 8/19/11, Andrew Welch <andrew.j.welch@gmail.com> wrote:

From: Andrew Welch <andrew.j.welch@gmail.com>
Subject: Re: [saxon] TransformerConfigurationException
To: "Mailing list for the SAXON XSLT and XQuery processor" <saxon-help@lists.sourceforge.net>
Date: Friday, August 19, 2011, 4:10 PM

> I'm running a XSL-FO to PDF code inside a JApplet. The code work fine as a stand alone module but it fails inside an applet throwing the exeption:
>
> --------------------------------------------------------------------------------------------------------------------------------
> javax.xml.transform.TransformerConfigurationException: Failed to compile stylesheet. 1 error detected.
>  at net.sf.saxon.PreparedStylesheet.prepare(PreparedStylesheet.java:124)

> <xsl:stylesheet version="1.1"
>  xmlns:xsl=http://www.w3.org/1999/XSL/Transform

You are missing the double quotes there...

Also, version 1.1 doesn't exist, you should change that to 2.0

You might also want to check how it worked fine locally, as that would
always cause an exception.

--
Andrew Welch
http://andrewjwelch.com

------------------------------------------------------------------------------
Get a FREE DOWNLOAD! and learn more about uberSVN rich system,
user administration capabilities and model configuration. Take
the hassle out of deploying and managing Subversion and the
tools developers use with it. http://p.sf.net/sfu/wandisco-d2d-2
_______________________________________________
saxon-help mailing list archived at http://saxon.markmail.org/
saxon-help@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/saxon-help