This error indicates that you are trying to run the old "Instant Saxon" product, which relied on the Microsoft Java VM. Microsoft stopped distributing this JVM about five years ago after their lawsuit with Sun. Please use a more recent version of Saxon, in conjunction with a Java VM that supports JDK 1.4 or later (typically the Sun JVM). The current release is Saxon 9.0.0.2, which supports XSLT 2.0; or if you really want to use the XSLT 1.0 Saxon processor, Saxon 6.5.5 remains available. See http://saxon.sf.net/ for details.
 
There is also an implementation of Saxon 9.0.0.2 that runs on .NET, if you prefer.
 
Michael Kay
Saxonica Limited