This is really a Xerces question rather than a Saxon question. I think the dependency on Attributes2 comes from Xerces, not from Saxon. I don't actually know whether Xerces 2.9.1 is supported on JDK 1.4.
 
I downloaded 2.9.1 and took a look at it; I would have expected SAX2 to be present in the xml-apis.jar file, but it seems that contains SAX1. You may be able to make it work with SAX2 downloaded directly from SourceForge, but I can't vouch for it. Unless anyone else here knows the answer, please ask on a Xerces forum.
 
Michael Kay
http://www.saxonica.com/


From: saxon-help-bounces@lists.sourceforge.net [mailto:saxon-help-bounces@lists.sourceforge.net] On Behalf Of Kermit Tensmeyer
Sent: 25 January 2008 01:59
To: saxon-help ML
Subject: [saxon] Attribute2 Error

I'm trying to get XSL V2  and xinclude working.
 [The short term project is to generate SUSE autoyast xml files using XSL. The method in current process uses sed, awk,and
multiple files concatenated with some  xmllintprocessing and a lot of messy file edits and tweaks.
I've argued that XSL is a far better method of XML file generation for a  while.] [it's a put up or shut up challenge...]

  I've used emacs and nxml to get most of the stuff inplace properly
 and tested with Oxygen running under Windows to generate mostly correct output.

and now run on Linux with

ibmkt@lxwkbc194:~/yast> java -version
   java version "1.4.2"
   Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2)
   Classic VM (build 1.4.2, J2RE 1.4.2 IBM build cxz641420-20040626 (JIT
   enabled: jitc))

 where the   OS is   SLES9 on Z/OS mainframe.
    upgrading the java version or the OS is not an option (otherwise the OS is
    not a consideration)

I'd like to start with the same files (xml, xsl, xsd) in a linux environment
using Saxon 9b in a cli environment. Earlier today I had problems making xinclude work
properly, (it complained about the SAX processor) I think I understand the issues but it's taken time

In order to get xinclude working, I brought in Xerces 2.9.1 files and created
an /usr/lib/java/jre/lib/endorsed directory and added the files.

I'm using a shortcut shell script ~/bin/saxonj

java -cp  "/home/ibmkt/saxon/saxon9.jar:$CLASSPATH"  \
    -Djavax.xml.parsers.DocumentBuilderFactory=\
org.apache.xerces.jaxp.DocumentBuilderFactoryImpl \
    -Djavax.xml.parsers.SAXParserFactory=\
org.apache.xerces.jaxp.SAXParserFactoryImpl  \
    -Dorg.apache.xerces.xni.parser.XMLParserConfiguration=\
org.apache.xerces.parsers.XIncludeParserConfiguration \
 net.sf.saxon.Transform "$@"

and when I execute on command line

> saxonj -xsl:tmplate.xsl -o:out1.xml -xi:on     ktest.xml

  I get
Exception in thread "main" java.lang.NoClassDefFoundError: org/xml/sax/ext/Attributes2
        at org.apache.xerces.parsers.AbstractSAXParser.<init>(Unknown Source)
        at org.apache.xerces.parsers.SAXParser.<init>(Unknown Source)
        at org.apache.xerces.parsers.SAXParser.<init>(Unknown Source)
        at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.<init>(Unknown Source)
        at org.apache.xerces.jaxp.SAXParserImpl.<init>(Unknown Source)
        at org.apache.xerces.jaxp.SAXParserFactoryImpl.newSAXParser (Unknown Source)
        at net.sf.saxon.Configuration.loadParser(Configuration.java:1773)
        at net.sf.saxon.Configuration.getStyleParser(Configuration.java:1804)
        at net.sf.saxon.PreparedStylesheet.loadStylesheetModule (PreparedStylesheet.java:235)
        at net.sf.saxon.PreparedStylesheet.prepare(PreparedStylesheet.java:162)
        at net.sf.saxon.TransformerFactoryImpl.newTemplates(TransformerFactoryImpl.java:139)
        at net.sf.saxon.Transform.doTransform(Transform.java:636)
        at net.sf.saxon.Transform.main(Transform.java:65)
 
     what other jars do I need to supply that will satisfy the Attributes2 class?
------------------------