Hi,

 

I got interested in Saxon recently in hopes of generating multiple html files from a single XML doc. While I’ve had some luck running through the sample applications provided in the documentation, I seem to be unable to run either the Shakespeare or Bible examples successfully.

 

This is the first time that I’ve attempted to install Saxon and I’m running Windows2000 w/ Java v. 1.4. Based on what I’ve already read on this and other lists, I’m assuming that the problem has something to do with an incorrectly set CLASSPATH because any attempt to invoke “java net.sf.saxon.Transform…” results in an “Exception in thread “main” java.lang.NoClassDefFoundError: net/sf/saxon/Transform” error.

 

For the other sample applications, I could get around this error by using the -jar method to generate results. So I tried:

 

java -jar c:\saxon\saxon7.jar data\othello.xml styles\play.xsl dir=playhtml

 

The only trouble is that, though the class not found error is taken care of in this case, the above command only yields, “<?xml version=”1.0” encoding=”utf-8”?>.” for results.

 

Any suggestions? I’ve tried every variation I can think of for changing $CLASSPATH and am fresh out of ideas. Hopefully, I’m missing something simple here, but I’m not familiar enough with Java to know exactly what to do to address the problem.

 

Thanks,

 

-Ben

--
Ben Caldwell | caldwell@trace.wisc.edu
Trace Research and Development Center (http://trace.wisc.edu)