Dear all,
 
I have just noticed through my Eclipse version 3 that following packages are missing inside javax e.g.
 
javax.xml.namespace.*
javax.xml.xpath.*
 
and following are present
 
javax.xml.parser.*
javax.xml.transform.dom
javax.xml.transform.sax
javax.xml.transform.stream
 
 
I think there is a problem with the jar file that i have downloaded i.e. jaxp-api.jar n dom.jar) , can any body provide me the correct version/path  of the file. becaz i have downloaded the jwsdp-1.5 and it contained these files under jaxp-api.jar n dom.jar
 
 
 
regards
Muhammad.
 
 
----- Original Message -----
From: Michael Kay
To: saxon-help@lists.sourceforge.net
Sent: Sunday, February 20, 2005 11:42 PM
Subject: RE: [saxon] problems in configuring Saxon

I don't know Eclipse, I'm afraid. But check your copy of jaxp-api.jar - I'm pretty sure you'll find these two classes inside it.
 
I'm afraid Sun have made the download of the freestanding JAXP 1.3 very complicated and I can't make it any simpler for you. If you've got the files from jwsdp-1.5 then you're past that hurdle: check the contents of the JAR just to make sure, but I'm pretty sure you'll find they are there.
 
The IDE that I use (IntelliJ) allows you to have different JAR files in scope for different parts of your project. I don't know if Eclipse is similar, but that can sometimes lead to configuration problems of this kind.
 
Michael Kay
http://www.saxonica.com/


From: saxon-help-admin@lists.sourceforge.net [mailto:saxon-help-admin@lists.sourceforge.net] On Behalf Of Muhammad Masoom Alam
Sent: 20 February 2005 16:07
To: saxon-help@lists.sourceforge.net
Subject: Re: [saxon] problems in configuring Saxon

Hi,
thanks for the prompt reply
 
As for as the classpath is concerned, i am Using Eclipse and its never a problem with eclipse to set a path to an external Jar file , i means through project properties--> Add external jars, if u want me to do the manual excercise, i will do it and let u know about the results i.e. manualy setting the classpath , but normally with Eclipse it works i dont know why it is not working right now
 
 
 
 
but one thing, i have not downloaded these two files seperately but as part of sun jwsdp-1.5 and picked these 2 jar files (jaxp-api.jar n dom.jar ) from there. is this ok ??
 
regards
Muhammad.
PS:if u can plz give me the address of these files on the sun website, as it is difficult to find them seperately
 
 
----- Original Message -----
From: Michael Kay
To: saxon-help@lists.sourceforge.net
Sent: Sunday, February 20, 2005 4:33 PM
Subject: RE: [saxon] problems in configuring Saxon

The classes javax.xml.namespace.QName and javax.xml.xpath.XPathVariableResolver are both in the jaxp-api.jar file, so if they aren't being found, then Java isn't finding this JAR file on your classpath. Check the classpath very carefully - Java doesn't give you any error messages if you spell the name incorrectly.
 
A useful test is to use exactly the same classpath, and type
 
javap javax.xml.namespace.QName
 
If that fails, then you know that the problem is nothing to do with Saxon.
 
If you still have problems, please let is know exactly what you are doing.
 
Michael Kay
http://www.saxonica.com/
 


From: saxon-help-admin@lists.sourceforge.net [mailto:saxon-help-admin@lists.sourceforge.net] On Behalf Of Muhammad Masoom Alam
Sent: 20 February 2005 13:36
To: saxon-help@lists.sourceforge.net
Subject: [saxon] problems in configuring Saxon

Dear all,
I am new user of Saxon
 
i have problems in confirguring Saxon compiler on my system.
 
All libraries are on the class path , but still i am getting errors for not resovling some thing e.g.
 
samples package contains one java file XPathExample.java it is giving me 2 errors
1. The interface XPathVariableResolver cant be resolved
2. The type javax.xml.namespace.Qname cannot be resolved It is indirectly referenced from required .class files
 
 
I am using Jdk 1.4 and using dom.jar and jaxp-api.jar seperately as in the installation instruction
 
regards
Muhammad.