#1058 Compiling stylesheets for Saxon-HE

v9.2
closed
Michael Kay
5
2012-10-08
2010-04-09
Michael Kay
No

The intention of the feature packaging in Saxon 9.2 is that the ability to compile XSLT stylesheets (the com.saxonica.CompileStylesheet command) should only be available in Saxon-EE, but it should be possible to execute the resulting stylesheets under Saxon-HE provided they use no Saxon-EE features. This is not working; the compiled stylesheets will only execute under Saxon-EE. A patch is being raised to fix this. Note that to take advantage of this facility, the CompileStylesheet command needs to load a Saxon-HE configuration, which can be achieved using the option -config:he.config, where he.config is the name of a configuration file containing as a minimum

<configuration edition="HE" xmlns="http://saxon.sf.net/ns/configuration"/>

Discussion

  • Michael Kay
    Michael Kay
    2010-04-26

    Fixed in 9.2.1.1