Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#18 gucharmap slackware package should be recompiled

closed
nobody
None
14.0
Defect
Critical
2013-06-10
2012-12-26
No

gucharmap does not work, missing library : libgtk-3.so.0 (should be recompiled against gtk2?)
This is critical because it's included by default in Salix Xfce 14.0 ISO.

Discussion

  • I know. Look in the "known issues" at the end of the announcement: http://www.salixos.org/forum/viewtopic.php?f=17&t=4150

    I'm not going to rebuild gucharmap with gtk+2. I don't even think it's possible to build it with gtk+2. In any case it would create incompatibilities with slackware.

    The dependencies in the repos are correct, as they are listing gtk+3. Sadly nobody noticed during testing that it didn't work. The only way to really fix this is to create a new iso that will not include gucharmap (and that's what I'm going to do).

     
  • gucharmap will be removed from future isos. So, this is solved.

     
    • status: open --> closed