Hi

On 16 April 2013 19:09, <j.merrill@enlyton.com> wrote:

My first uses of s3cmd worked fine; in particular,

 

s3cmd ls s3://MyBucket/SubBucket/

 

returned exactly the info I wanted (about some files and a sub-sub-bucket that I wanted to copy down to my PC).  So then I tried (with the directory I wanted as the "target" being the current directory) and got the message below.  An oddity is that when done, there were no directories added to the current directory, making the message not easily explained.

 

I'm thinking of modifying cmd_object_get so that it displays what it's passing to the os.makedirs.  But Python is not my language of choice....will it all "just work" if I change one of the .py files and run it again?  (Perhaps I'll send more before you get to answer.)


Yes, that should work fine.

[...]
File "c:\python26\lib\os.py", line 157, in makedirs

mkdir(name, mode)

WindowsError: [Error 183] Cannot create a file when that file already exists: u'.'


It looks like it's trying to create the current directory.  i.e. mkdir(".")
 

Thanks for any help you can provide.

J. Merrill


--
Michael Wood <esiotrot@gmail.com>