Please try a newer version such as upstream master branch.  Several unicode-related issues have been fixed since then.  And be sure you're using a LANG= value that includes unicode, such as LANG=en_US.UTF-8.




On Fri, Feb 21, 2014 at 5:02 PM, Jeff Andersen <jandersen@rbl.net> wrote:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    An unexpected error has occurred.
  Please report the following lines to:
   s3tools-bugs@lists.sourceforge.net
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Problem: UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 52: ordinal not in range(128)
S3cmd:   1.0.1

Traceback (most recent call last):
  File "/opt/local/bin/s3cmd", line 2006, in <module>
    main()
  File "/opt/local/bin/s3cmd", line 1950, in main
    cmd_func(args)
  File "/opt/local/bin/s3cmd", line 1213, in cmd_sync
    return cmd_sync_remote2local(args)
  File "/opt/local/bin/s3cmd", line 966, in cmd_sync_remote2local
    output(u"download: %s -> %s" % (remote_list[key]['object_uri_str'], remote_list[key]['local_filename']))
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 52: ordinal not in range(128)

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    An unexpected error has occurred.
    Please report the above lines to:
   s3tools-bugs@lists.sourceforge.net
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

--Jeff Andersen
   jandersen@rbl.net




------------------------------------------------------------------------------
Managing the Performance of Cloud-Based Applications
Take advantage of what the Cloud has to offer - Avoid Common Pitfalls.
Read the Whitepaper.
http://pubads.g.doubleclick.net/gampad/clk?id=121054471&iu=/4140/ostg.clktrk