I was running with a config file pointed at a Eucalyptus server.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    An unexpected error has occurred.
  Please report the following lines to:
   s3tools-bugs@lists.sourceforge.net
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Problem: ExpatErr: no element found: line 1, column 0
S3cmd:   0.9.9
Python:  2.4.3 (#1, Jul 27 2009, 17:56:30)  [GCC 4.1.2 20080704 (Red Hat 4.1.2-44)]

Traceback (most recent call last):
  File "/usr/bin/s3cmd", line 1569, in ?
    main()
  File "/usr/bin/s3cmd", line 1549, in main
    cmd_func(args)
  File "/usr/bin/s3cmd", line 90, in cmd_ls
    subcmd_buckets_list_all(s3)
  File "/usr/bin/s3cmd", line 103, in subcmd_buckets_list_all
    response = s3.list_all_buckets()
  File "/usr/lib/python2.4/site-packages/S3/S3.py", line 109, in list_all_buckets
    response = self.send_request(request)
  File "/usr/lib/python2.4/site-packages/S3/S3.py", line 402, in send_request
    raise S3Error(response)
  File "/usr/lib/python2.4/site-packages/S3/Exceptions.py", line 44, in __init__
    tree = getTreeFromXml(response["data"])
  File "/usr/lib/python2.4/site-packages/S3/Utils.py", line 57, in getTreeFromXml
    tree = ET.fromstring(xml)
  File "/usr/lib/python2.4/site-packages/elementtree/ElementTree.py", line 961, in XML
    return parser.close()
  File "/usr/lib/python2.4/site-packages/elementtree/ElementTree.py", line 1251, in close
    self._parser.Parse("", 1) # end of data
ExpatError: no element found: line 1, column 0

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    An unexpected error has occurred.
    Please report the above lines to:
   s3tools-bugs@lists.sourceforge.net


--
Mark