----------------------- This is the script -----------------------
[root:/] cat ./tos3.sh
echo s3cmd put -r -e --delete-removed /mnt s3://<bucket-nam>/$1/mnt/
s3cmd put -r -e --delete-removed /mnt s3://<bucket-name>/$1/mnt/

----------------------- This is how I run it ----------------------
[root:/] ./tos3.sh wednesday &

---------------------- I got this error ---------------------------
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Problem: ExpatErr: no element found: line 1, column 0
S3cmd:   0.9.9
Python:  2.4.3 (#1, Jan 14 2008, 18:31:21)  [GCC 4.1.2 20070626 (Red Hat 4.1.2-14)]

Traceback (most recent call last):
  File "/usr/bin/s3cmd", line 1562, in ?
    main()
  File "/usr/bin/s3cmd", line 1542, in main
    cmd_func(args)
  File "/usr/bin/s3cmd", line 335, in cmd_object_put
    response = s3.object_put(full_name, uri_final, extra_headers, extra_label = seq_label)
  File "/usr/lib/python2.4/site-packages/S3/S3.py", line 202, in object_put
    response = self.send_file(request, file, labels)
  File "/usr/lib/python2.4/site-packages/S3/S3.py", line 498, in send_file
    warning("Upload failed: %s (%s)" % (resource['uri'], S3Error(response)))
  File "/usr/lib/python2.4/site-packages/S3/Exceptions.py", line 44, in __init__
    tree = getTreeFromXml(response["data"])
  File "/usr/lib/python2.4/site-packages/S3/Utils.py", line 57, in getTreeFromXml
    tree = ET.fromstring(xml)
  File "/usr/lib/python2.4/site-packages/elementtree/ElementTree.py", line 961, in XML
    return parser.close()
  File "/usr/lib/python2.4/site-packages/elementtree/ElementTree.py", line 1251, in close
    self._parser.Parse("", 1) # end of data
ExpatError: no element found: line 1, column 0

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    An unexpected error has occurred.
    Please report the above lines to:
   s3tools-bugs@lists.sourceforge.net
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!