Hi,

I got the following error while trying to execute "s3cmd info" on a file. The command and the corresponding error is as shown below. My platform is Windows XP, 32 bit OS. 

C:\Python27\Scripts>python s3cmd info s3://savviss-buck1-bucket/tmp5.txt
ERROR: Option --progress is not yet supported on MS Windows platform. Assuming --no-progress.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    An unexpected error has occurred.
  Please report the following lines to:
   s3tools-bugs@lists.sourceforge.net
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Problem: ParseError: no element found: line 1, column 0
S3cmd:   1.0.1

Traceback (most recent call last):
  File "s3cmd", line 2006, in <module>
    main()
  File "s3cmd", line 1950, in main
    cmd_func(args)
  File "s3cmd", line 631, in cmd_info
    info = s3.object_info(uri)
  File "c:\python27\lib\site-packages\S3\S3.py", line 324, in object_info
    response = self.send_request(request)
  File "c:\python27\lib\site-packages\S3\S3.py", line 511, in send_request
    raise S3Error(response)
  File "c:\python27\lib\site-packages\S3\Exceptions.py", line 48, in __init__
    tree = getTreeFromXml(response["data"])
  File "c:\python27\lib\site-packages\S3\Utils.py", line 69, in getTreeFromXml
    tree = ET.fromstring(xml)
  File "c:\python27\lib\xml\etree\ElementTree.py", line 1283, in XML
    return parser.close()
  File "c:\python27\lib\xml\etree\ElementTree.py", line 1636, in close
    self._raiseerror(v)
  File "c:\python27\lib\xml\etree\ElementTree.py", line 1488, in _raiseerror
    raise err
ParseError: no element found: line 1, column 0

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    An unexpected error has occurred.
    Please report the above lines to:
   s3tools-bugs@lists.sourceforge.net
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

-Raj