Config issue

2009-05-28
2013-02-19
  • /usr/bin/s3cmd:662: DeprecationWarning: os.popen4 is deprecated.  Use the subprocess module.

    Err, help?

     
    • Forgot to post the version... This also blew an error, no errors were given during install (via apt-get) on Ubuntu Server 9.04.

      root@ubuntunas:~# s3cmd --version
      /usr/lib/python2.6/dist-packages/S3/S3.py:9: DeprecationWarning: the md5 module is deprecated; use hashlib instead
        import md5
      /usr/lib/python2.6/dist-packages/S3/S3.py:10: DeprecationWarning: the sha module is deprecated; use the hashlib module instead
        import sha
      s3cmd version 0.9.8.4

       
    • Michal Ludvig
      Michal Ludvig
      2009-05-28

      Hi,

      1) It's just a warning
      2) It's fixed in 0.9.9 and later.
      3) Ubuntu is really getting on my nerves - although s3cmd 0.9.9 was ready in time for Ubuntu 9.04 they decided to ship the old s3cmd 0.9.8.4, regardless of https://bugs.launchpad.net/ubuntu/+source/s3cmd/+bug/333651
      So yes, Ubuntu sucks. If you wish I can recommend you a better distribution ;-)

      Michal