gpd-3.3.1 build error

Developers
Anonymous
2011-08-09
2013-03-11

  • Anonymous
    2011-08-09

    Hi,

    I am trying to rebuild GPD 3.3.1 - I started by installing eclipse 3.5.1 (with WTP 1.5.4) and Jboss 4.0.5 as recommended and my build.properties file is set as follows:

    # In order to build GPD application you require eclipse WTP installation
    # Current WTP version is 1.5.4:
    # http://download.eclipse.org/webtools/downloads/drops/R1.5/R-1.5.4-200705021353/
    # You also require an RCP delta-pack installed to build for multiple platforms
    # http://download.eclipse.org/eclipse/downloads/drops/R-3.2.2-200702121330/index.php

    eclipse.home.dir=C:/Users/Downloads/eclipse-3.5.1/eclipse
    jboss.home.dir=C:/Users//Downloads/JBoss/JBoss AS/4.0.5/jboss-4.0.5.GA

    The ant build process failed and the ant log is as follows:

    build:
          Buildfile: C:/Users/Downloads/eclipse-3.5.1/eclipse/plugins/org.eclipse.pde.build_3.5.1.R35x_20090820/scripts/productBuild/productBuild.xml
         
          main:
         
          preBuild:
         
          preSetup:
         
          checkLocalMaps:
         
          getMapFiles:
         
          postSetup:
         
          checkLocalBase:
         
          getBaseComponents:
         
          processRepos:
         
          generateFeature:
         
          fetch:
         
          generateFeature:
           Some inter-plug-in dependencies have not been satisfied.
           Bundle org.jbpm.ui:
           Missing required plug-in org.eclipse.ui_0.0.0.
           Missing required plug-in org.eclipse.ui.views_0.0.0.
           Missing required plug-in org.eclipse.ui.ide_0.0.0.
           Missing required plug-in org.eclipse.jdt.ui_0.0.0.
           Missing required plug-in org.eclipse.ui.workbench.texteditor_0.0.0.
           Missing required plug-in org.eclipse.ui.editors_0.0.0.
           Missing required plug-in org.eclipse.gef_0.0.0.
           Missing required plug-in tk.eclipse.plugin.htmleditor_0.0.0.
           Missing required plug-in org.eclipse.search_0.0.0.
           Missing required plug-in org.eclipse.ltk.ui.refactoring_0.0.0.
           Bundle ru.runa.alfresco:
           Missing required plug-in org.eclipse.ui_0.0.0.
           Missing required plug-in org.jbpm.ui_0.0.0.
           Missing required plug-in tk.eclipse.plugin.wysiwyg_0.0.0.
           Bundle ru.runa.jbpm.ui:
           Missing required plug-in org.eclipse.ui_0.0.0.
           Missing required plug-in org.jbpm.ui_0.0.0.
           Missing required plug-in tk.eclipse.plugin.htmleditor_0.0.0.
           Missing required plug-in tk.eclipse.plugin.wysiwyg_0.0.0.
           Missing required plug-in org.eclipse.ui.ide_0.0.0.
           Bundle ru.runa.specific:
           Missing required plug-in org.jbpm.ui_0.0.0.
           Missing required plug-in tk.eclipse.plugin.wysiwyg_0.0.0.
           Missing required plug-in org.eclipse.ui_0.0.0.
           Missing required plug-in org.eclipse.ui.views_0.0.0.
           Missing required plug-in ru.runa.alfresco_0.0.0.
           Bundle tk.eclipse.plugin.htmleditor:
           Missing required plug-in org.eclipse.ui_0.0.0.
           Missing required plug-in org.eclipse.ui.editors_0.0.0.
           Missing required plug-in org.eclipse.ui.workbench.texteditor_0.0.0.
           Missing required plug-in org.eclipse.ui.ide_0.0.0.
           Missing required plug-in org.eclipse.ui.views_0.0.0.
           Missing required plug-in org.eclipse.update.ui_0.0.0.
           Missing required plug-in org.eclipse.gef_0.0.0.
           Missing required plug-in org.eclipse.jdt.ui_0.0.0.
           Missing required plug-in org.eclipse.debug.ui_0.0.0.
           Missing required plug-in org.eclipse.jdt.debug.ui_0.0.0.
           Bundle tk.eclipse.plugin.wysiwyg:
           Missing required plug-in tk.eclipse.plugin.htmleditor_0.0.0.
           Missing required plug-in org.eclipse.ui_0.0.0.
           Missing required plug-in org.eclipse.ui.editors_0.0.0.
           Missing required plug-in org.eclipse.ui.workbench.texteditor_0.0.0.
           Missing required plug-in org.jbpm.ui_0.0.0.
           Missing required plug-in org.eclipse.ui.ide_0.0.0.
           Bundle com.ibm.icu:
           Another singleton version selected: com.ibm.icu_3.4.5.20061213
           Bundle org.eclipse.acceleo.doc:
           Missing required plug-in org.eclipse.help_0.0.0.
           Bundle org.eclipse.acceleo.examples:
           Missing required plug-in org.eclipse.ui_0.0.0.
           Missing required plug-in org.eclipse.ui.ide_0.0.0.
           Bundle org.eclipse.acceleo.ide.ui:
           Missing required plug-in org.eclipse.ui_0.0.0.
           Missing required plug-in org.eclipse.ui.editors_0.0.0.
           Missing required plug-in org.eclipse.emf.edit.ui_0.0.0.
           Missing required plug-in org.eclipse.jdt.ui_0.0.0.
           Missing required plug-in org.eclipse.ui.ide_0.0.0.
           Missing required plug-in org.eclipse.debug.ui_0.0.0.
           Missing required plug-in org.eclipse.ui.console_0.0.0.
           Missing required plug-in org.eclipse.search_0.0.0.
           Missing required plug-in org.eclipse.emf.ecore.editor_0.0.0.
           Missing required plug-in org.eclipse.jdt.debug.ui_0.0.0.
           Missing required plug-in org.eclipse.search_0.0.0.
           Missing required plug-in org.eclipse.ui.workbench.texteditor_0.0.0.
           Bundle org.eclipse.acceleo.ui.capabilities:
           Missing required plug-in org.eclipse.ui_3.4.0.
           Bundle org.eclipse.ant.core:
           Another singleton version selected: org.eclipse.ant.core_3.2.101.v20091110_r352
           Bundle org.eclipse.ant.core:
           Another singleton version selected: org.eclipse.ant.core_3.2.101.v20091110_r352
           Bundle org.eclipse.ant.ui:
           Another singleton version selected: org.eclipse.ant.ui_3.4.2.v20091204_r352
           Optional plug-in org.eclipse.ui.ide_[3.2.0,4.0.0) is not available.
           Optional plug-in org.eclipse.ui.views_[3.2.0,4.0.0) is not available.
           Optional plug-in org.eclipse.ui.workbench.texteditor_[3.2.0,4.0.0) is not available.
           Optional plug-in org.eclipse.ui.editors_[3.2.0,4.0.0) is not available.
           Missing required plug-in org.eclipse.ui.externaltools_[3.1.0,4.0.0).
           Missing required plug-in org.eclipse.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.ui.console_[3.1.0,4.0.0).
           Missing required plug-in org.eclipse.debug.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.jdt.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.jdt.debug.ui_[3.2.0,4.0.0).
           Bundle org.eclipse.ant.ui:
           Another singleton version selected: org.eclipse.ant.ui_3.4.2.v20091204_r352
           Optional plug-in org.eclipse.ui.ide_[3.2.0,4.0.0) is not available.
           Optional plug-in org.eclipse.ui.views_[3.2.0,4.0.0) is not available.
           Optional plug-in org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0) is not available.
           Optional plug-in org.eclipse.ui.editors_[3.2.0,4.0.0) is not available.
           Missing required plug-in org.eclipse.ui.externaltools_[3.1.0,4.0.0).
           Missing required plug-in org.eclipse.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.ui.console_[3.1.0,4.0.0).
           Missing required plug-in org.eclipse.debug.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.jdt.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.jdt.debug.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.jdt.junit_3.5.0.
           Bundle org.eclipse.ant.ui:
           Optional plug-in org.eclipse.ui.ide_[3.2.0,4.0.0) is not available.
           Optional plug-in org.eclipse.ui.views_[3.2.0,4.0.0) is not available.
           Optional plug-in org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0) is not available.
           Optional plug-in org.eclipse.ui.editors_[3.2.0,4.0.0) is not available.
           Missing required plug-in org.eclipse.ui.externaltools_[3.1.0,4.0.0).
           Missing required plug-in org.eclipse.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.ui.console_[3.1.0,4.0.0).
           Missing required plug-in org.eclipse.debug.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.jdt.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.jdt.debug.ui_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.jdt.junit_3.5.0.
           Bundle org.eclipse.compare.core:
           Unsatisfied import package com.ibm.icu.text_3.6.1.
           Unsatisfied import package com.ibm.icu.util_3.6.1.
           Bundle org.eclipse.compare.win32:
           Missing required plug-in org.eclipse.compare_[3.5.0,4.0.0).
           Missing required plug-in org.eclipse.ui.workbench_[3.5.0,4.0.0).
           Bundle org.eclipse.compare:
           Another singleton version selected: org.eclipse.compare_3.5.2.r35x_20100113-0800
           Missing required plug-in org.eclipse.ui_[3.1.0,4.0.0).
           Missing required plug-in org.eclipse.ui.ide_[3.1.0,4.0.0).
           Missing required plug-in org.eclipse.ui.views_[3.1.0,4.0.0).
           Missing required plug-in org.eclipse.ui.workbench.texteditor_[3.1.0,4.0.0).
           Bundle org.eclipse.compare:
           Another singleton version selected: org.eclipse.compare_3.5.2.r35x_20100113-0800
           Missing required plug-in org.eclipse.ui_[3.5.0,4.0.0).
           Missing required plug-in org.eclipse.ui.ide_[3.3.0,4.0.0).
           Missing required plug-in org.eclipse.ui.views_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0).
           Missing required plug-in org.eclipse.ui.editors_[3.5.0,4.0.0).
           Missing required plug-in org.eclipse.compare.core_[3.5.0,4.0.0).
           Bundle org.eclipse.compare:
           Missing required plug-in org.eclipse.ui_[3.5.0,4.0.0).
           Missing required plug-in org.eclipse.ui.ide_[3.3.0,4.0.0).
           Missing required plug-in org.eclipse.ui.views_[3.2.0,4.0.0).
           Missing required plug-in org.eclipse.ui.workbench.texteditor_[3.5.0,4.0.0).
           Missing required plug-in org.eclipse.ui.editors_[3.5.0,4.0.0).
           Missing required plug-in org.eclipse.compare.core_[3.5.0,4.0.0).
           Bundle org.eclipse.core.contenttype:
           Another singleton version selected: org.eclipse.core.contenttype_3.4.1.R35x_v20090826-0451
           Bundle org.eclipse.core.expressions:
           Another singleton version selected: org.eclipse.core.expressions_3.4.101.R35x_v20100209
    .
    .
    .
     
          BUILD FAILED
          C:\Users\Downloads\eclipse-3.5.1\eclipse\plugins\org.eclipse.pde.build_3.5.1.R35x_20090820\scripts\productBuild\productBuild.xml:36: The following error occurred while executing this line:
          C:\Users\Downloads\eclipse-3.5.1\eclipse\plugins\org.eclipse.pde.build_3.5.1.R35x_20090820\scripts\productBuild\productBuild.xml:64: Unable to find plug-in: org.eclipse.compare_0.0.0. Please check the error log for more details.
         
          Total time: 6 seconds

    BUILD FAILED
    C:\Users\Downloads\RunaWF\3.3.1-release-2011-03-23\Graphical-Process-Designer\gpd-3.3.1-r3035-src\gpd\build.xml:12: Java returned: 13

    Total time: 29 seconds

    In there a special eclipse configuration need to rebuild GPD 3.3.1 or there is something am not doing right.

    Look forward to hearing you.

     

  • Anonymous
    2011-08-10

    Hi,

    Any help on how why gpd-3.3.1 build is failing as mentioned above? Any help on this will be greatly appreciated.

    Thanks.