Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#13 Crashes with BUS ERROR on OS X / intel, when used with rails

open
nobody
None
5
2006-12-08
2006-12-08
Anonymous
No

$ script/console
Loading development environment.
>> require 'ldap'
=> true
>> LDAP::Conn.open
(irb):4: [BUG] Bus Error
ruby 1.8.4 (2005-12-24) [i686-darwin8.8.1]

However from plain irb, it runs fine. I presume it's clashing with some other code Rails pulls in. Bit of a show-stopper as far as I'm concerned.

Discussion

  • Logged In: NO

    Further info

    OSX 10.4.8 Ruby/LDAP version 0.9.1, Rails version 1.2 (edge) I get a bus error as well. Using under Rails, I've previously had bus errors on other packages and got around them by requiring them in the dispatcher, however no dice with this one, doesn't matter where I require it I get an error when trying to access LDAP::Conn. I suspect I'm going to have to do a nasty shell script hack work around to call it via a shell script outside of rails and get the output back.

    If this is fixed I would be most grateful !

    Thanks,
    Rowan - ubermunkey@gmail.com