Frequent Crashing

Help
2012-04-19
2012-08-29
  • jemofthewest
    jemofthewest
    2012-04-19

    Hi all, first time bug report so bear with me :-)

    I've recently started to try this after reading the Lifehacker article, I
    connected it with my gmail account (which has a ton of feeds), and it takes a
    little while to update all of them. When it finally updates, I've been
    clicking on Huffington Post and it'll crash after the first article pops up.
    It then doesn't start up again so I haven't been able to see if other feeds
    cause this. Another thing that might be involved is it happens after I run the
    clean up. Anyways, these files keep cropping up in my home folder so I'm
    assuming their pertinent...

    http://pastebin.com/F8Dwkmt9

    That should have all my information so let me know if there is anything else
    you need to know... thanks!

     
  • genodeftest
    genodeftest
    2012-04-19

    Hi

    Thanks for this much information. Looks like the buggy unstable Flashplayer
    crashed and killed RSSOwl… . One article currently "opened" (should be visible
    on startup, but does not since RSSOwl gets crashed) contains a Flash object.
    Every time you start RSSOwl the internal browser tries to load this Flash
    content and crashes again.

    So we need to start RSSOwl without flashplayer. The easiest way to do this:

    1. make sure RSSOwl does not run (use top/htop/gnome-system-monitor/ksysguard/whatever you like)
    2. locate your home folder, go to ".mozilla/eclipse/prefs.js", you may need to make hidden files visible (Ctrl+H in Nautilus)
    3. add those lines at the end of prefs.js:

      user_pref("dom.ipc.plugins.enabled", false);
      user_pref("security.xpconnect.plugin.unrestricted", false);
      user_pref("plugins.click_to_play", false);
      user_pref("dom.ipc.plugins.timeoutSecs", -1);

    4. save prefs.js and try starting RSSOwl again, ideally from terminal. If it crashes again report it here.
      Plugins like Flash are now disabled in RSSOwl. To enable them again, just
      delete those lines from prefs.js. The problem may or may not occurr again, the
      safest way would be to keep flash disabled.

     
  • jemofthewest
    jemofthewest
    2012-04-21

    As far as I can tell, it's working again! Thanks so much!

    I did end up uninstalling rssowl because I'm running archlinux on a 16gb flash
    drive and forgot how much space a feed reader takes up :-) I will install when
    I make the move to installing onto the hard drive... thanks!

    Might be important, might be not but I removed the file again and wans't able
    to reproduce to error but I got it at least 10+ times before so I dunno what
    happened... thanks for the great program!