Still Getting Missing Browser Error on CentOS

Help
Anonymous
2012-07-10
2012-08-29

  • Anonymous
    2012-07-10

    I had a working installation of 2.1.2 on Linux Mint 13. This is the only Linux
    install where RSSOwl has worked for me.

    I copied the /usr/bin/rssowl file, the ~/.rssowl and /usr/lib/rssowl
    directories from that installation to my CentOS installation. I am still
    receiving the missing browser error.

    I have added
    "-Dorg.eclipse.swt.browser.XULRunnerPath=./usr/lib/rssowl/xulrunner" to both
    the /usr/bin/rssowl script and I've tried adding it to ./rssowl in a terminal.
    No go. Same error message.

    I remain with no explanation of why RSSOwl will so persistently not run, and
    why the release notes and the FAQ contradict each other about xulrunner.

     
  • genodeftest
    genodeftest
    2012-07-10

    Hi

    Did you try the .zip files from
    http://www.rssowl.org/download ? Seems like
    the package you installed is corrupt (wrong dependencies).

     

  • Anonymous
    2012-07-10

    No go on the installation from rssowl.org. That, as well as the files copied
    from Mint, launch and synch with Google Reader correctly. I consistently
    receive that browser error when I click on on the name of a feed in the left
    column.

    The version of lubhunspell installed by CenTOS is 1.2. That's the correct
    version. No need to to fake RSSOwl out with a link.

    I have installed RSSOwl on several versions of Linux, from repositories and
    from rssowl.org. With the exception of the Mint install which came from the
    Getdeb site, they have all failed to work, in the same way.

     
  • genodeftest
    genodeftest
    2012-07-10

    Do you have the correct architecture? (of RSSOwl, your Java Installation and
    libhunspell)

    Any Error output on console?

    Anything in the log files (
    http://www.rssowl.org/help#item_5 )?

    I have RSSOwl running on Fedora 17 which should be similar to RHEL/CentOS –
    the only thing I needed to change was the libhunspell version.

     

  • Anonymous
    2012-07-12

    OK, installed RSSOwl from the download link to a new Fedora 17 install. Made
    the libhunspell link. Refuses to launch, producing this error:

    /RSSOwl: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory

     
  • genodeftest
    genodeftest
    2012-07-12

    Seems like the architecture of RSSOwl, your Java Installation and your Fedora
    do not match. They have to be the same all together. If you have multiple
    architecture software, make sure that the correct one is used.