RSSOwl Can't Create a Browser

Help
2011-03-28
2013-07-09
<< < 1 2 3 4 (Page 4 of 4)
  • Chris
    Chris
    2012-03-19

    I don't think it's xulrunner. First my xulrunner was compiled with HunSpell
    1.2.9, recompiling with 1.3.2 does not fix the problem for me.

    Before recompiling xulrunner tried starting RSSOwl with:

    RSSOwl -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner-1.9.2.17/

    RSSOwl is not accepting the command line option. Looking at the About,
    Configuration Details, the option is not shown after *** System properties:

    Putting it in config.ini after results in:

    *** System properties:
    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner-1.9.2.17/

    Yet the is the XULRunnerPath:

    org.eclipse.swt.browser.XULRunnerPath=/usr/lib64/RSSOwl/xulrunner

    Nothing I do will get RSSOwl to recognize the /usr/lib64/xulrunner-1.9.2.17/
    path

    Renaming /usr/lib64/RSSOwl/xulrunner/ simply breaks RSSOwl and give me the
    can't create browser dialog.

    The only thing that works is creating a symlink.

     
  • genodeftest
    genodeftest
    2012-03-19

    Did you try adding

    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib64/xulrunner-1.9.2.17/
    to rssowl.ini file?

     
  • Chris
    Chris
    2012-03-19

    Yes. Read my last post.

     
  • Omega Weapon
    Omega Weapon
    2012-04-01

    uname -a: Linux 3.2.0-2-amd64 #1 SMP Tue Mar 20 18:36:37 UTC 2012 x86_64
    GNU/Linux (Debian Testing)

    Thanks to this thread I was able to get a working 64bit RSSOwl install for my
    user. I made a script out of vsego's point that the zip did not maintain the
    proper file permissions (...):

     1
     2
     3
     4
     5
     6
     7
     8
     9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    #!/bin/bash
    
    # This script is to chmod +x any executables in the given directory, no matter how nested they are
    
    # Making sure a valid directory was passed
    [[ ! -d "$1" ]] && {
        echo 'Please provide a valid directory!' > /dev/stderr
        exit 1
    }
    
    # Enabling globstar (the recursive glob)
    shopt -s globstar
    
    # Setting wordsplitting
    OIFS="$IFS"
    
    # Looping for all executable files in passed directory
    IFS=$'\n'
    for executable in $(file "$1"/** | grep executable | sed 's/:.*//')
    do
        # Checking if file isn't actually executable
        [[ ! -e $file ]] && {
    
        # It isnt - fixing
        echo "Making '$executable' executable..."
        chmod +x "$executable"
        }
    done
    
    # Restoring wordsplitting
    IFS="$OIFS"
    

    I run RSS owl in a non-standard location as I dont unmanaged non-native
    programs polluting my filesystem. Because of this, xulrunner's shared
    libraries cant be found, so I set LD_LIBRARY_PATH to the xulrunner directory
    path, e.g. testing with bash in the RSS Owl directory:

    LD_LIBRARY_PATH=./xulrunner/ ./RSSOwl

    The next problem was the following (as mentioned by others earlier in the
    thread):

    ./xulrunner-bin: error while loading shared libraries: libhunspell-1.2.so.0:
    cannot open shared object file: No such file or directory

    I couldnt care less about spelling so I locate'd the current version of the
    library (1.3) on the system then symlinked it the xulrunner directory under
    the name it wants:

    ln -s /usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0 ./libhunspell-1.2.so.0

    Ran RSSOwl again and it finally worked.... hopefully the spelling library's
    interface didnt change much between the two versions ;)

    I was almost going to move to Liferea over this mess.... thanks to this thread
    I worked it out just in time.

     
  • tgutwin
    tgutwin
    2012-10-31

    Fixed same problem on Ubuntu 12.10.

    Two issues to work-around

    1. The LD_LIBRARY_PATH for the xulrunner installed in RSSOWL
    * cd to the RSSOwl Install dir then run
    * LD_LIBRARY_PATH=./xulrunner/ ./RSSOwl

    2. It then complains about a problem with xulrunner requiring libhunspell
    * xulrunner-bin: error while loading shared libraries: libhunspell-1.2.so.0: cannot open shared object file: No such file or directory
    * Ubuntu 12.10 default package is libhunspell-1.3-0 with the correspondig library file
    * So I kludged it with a symbolic link
    * sudo ln -s /usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0 /usr/lib/x86_64-linux-gnu/libhunspell-1.2.so.0

    Now it works! when I run
    LD_LIBRARY_PATH=./xulrunner/ ./RSSOwl


     
<< < 1 2 3 4 (Page 4 of 4)