RSSOwl Can't Create a Browser

Help
2011-03-28
2013-07-09
<< < 1 2 3 4 > >> (Page 2 of 4)
  • I am bundling the 64 Bit version of XULRunner, I guess you have RSSOwl 64
    Bits? Can you send logs?

     
  • You can also try to rename the "xulrunner" folder in the rssowl dir to see if
    it is able to pick up the XULRunner from your linux.

     
  • looonger
    looonger
    2011-07-21

    I've installed xulrunner-1.9.2, rssowl- 2.0.6 and removed config folder
    .rssowl2. Strangely I still get the same message. Here's my log

    http://paste.org/pastebin/view/36371

     
  • CB
    CB
    2011-07-24

    I suddenly had this issue after upgrading from RSSOwl 2.0.6 to 2.1.0 on Ubuntu
    10.04 64bit. As one of my feeds gets displayed on startup, RSSOwl didn't even
    start after displaying this error twice.

    After fiddling around with it for a while, deinstalling and reinstalling
    RSSOwl and several versions of xulrunner (from repositories), extracting and
    pointing to the version of xulrunner as described in the
    FAQ (a link to
    http://www.rssowl.org/help#item_7a
    sure would be helpful there...), and testing the tweaks of
    /usr/share/rssowl/RSSOwl.ini and /usr/share/rssowl/configuration/config.ini as
    suggested in this thread, the only thing that worked was genodeftest's
    solution from post #16 above: Appending

    -Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-1.9.2.18
    

    to /usr/share/rssowl/RSSOwl.ini.

    As this ‚solution‘ would be deprecated with the next update of xulrunner, it
    most certainly was not an acceptable and permanent solution for me. So, what
    seems to work for me, is to rename the directory

    /usr/share/rssowl/xulrunner
    

    to anything else (I guess it could even be removed, though), so RSSOwl would
    not find it when starting up and apparently use the system's installed version
    of xulrunner as fallback which I could confirm via Help > About RSSOwl >
    Configuration Details:
    org.eclipse.swt.browser.XULRunnerPath=/usr/lib/xulrunner-1.9.2.18 now as
    opposed to org.eclipse.swt.browser.XULRunnerPath=/usr/share/rssowl/xulrunner
    before (the latter line only shows in the log after first failed try to open
    a feed).

    But I assume that even this solution would not survive the next update of
    RSSOwl.

    Can I provide you with any before and after logs or something to help solve
    it? Seems like the issue is not gone for everyone with 2.1.0 – for me it even
    appeared with the upgrade to this version...

    Anyway, thanks for RSSOwl. :-)

    Regards,

    CB

     
  • We should have a support team for XULRunner issues on Linux. I am starting to
    not care, its an incredibly bad situation.

     
  • CB
    CB
    2011-07-25

    I just checked: I'm getting my version of RSSOwl from the GetDeb.net
    repositories. They usually provide pretty up-to-date versions explicitly
    compiled for the respective versions of Ubuntu. Maybe they did something wrong
    in the Ubuntu 10.04 version of RSSOwl (2.1-1~getdeb1)? I'm thinking about
    opening up a bug report there...

    In case the error does not lie there, maybe your bundled version of xulrunner
    just needs a little tweaking, some executable permissions in some files or
    whatever (seeing how the contents and permissions differ in the several
    versions of xulrunner on my system).

    So still: Any logs or other info I can provide you with to help hopefully get
    rid of this issue? Don't give up now, please. Doesn't it work out of the box
    for most people? :-)

     
  • Well I have tested the version of RSSOwl on 32 Bit linux on my ubuntu VM and
    it correctly picks up the XULRunner from there, I am not sure about 64 Bits
    though. Its interesting that there is a repository for RSSOwl at getdeb.net, I
    was not aware of that. Are you in contact with these people? I am wondering if
    I could explicitly link to that site from rssowl.org for those wanting to
    install RSSOwl through a package manager.

    When you install from GetDeb.net, does it include the XULRunner folder?

     
  • CB
    CB
    2011-07-25

    Its interesting that there is a repository for RSSOwl at getdeb.net, I was
    not aware of that. Are you in contact with these people?

    Nope, I'm just using it. And the bug reports have to be done via
    Launchpad.

    I am wondering if I could explicitly link to that site from rssowl.org

    Why not? They are providing instructions and even a DEB file to add the repo
    to Ubuntu's sources right on their
    site
    . Though, not for all
    Ubuntu versions RSSOwl is currently available at its latest version, but at
    least for the current stable of Ubuntu (11.04) and the current LTS (10.04)
    RSSOwl is up to date:
    http://www.getdeb.net/software/RSSOwl

    When you install from GetDeb.net, does it include the XULRunner folder?

    Yes, it does come with the folder /usr/share/rssowl/xulrunner -- which I had
    to rename/remove as stated above. I pasted its content here:
    http://pastebin.com/9HrpryLR

     
  • Are you on 64 Bits?

     
  • CB
    CB
    2011-07-25

    Yep, Ubuntu 10.04 64bit.

     
  • CB
    CB
    2011-07-25

    Browsing through the xulrunner-1.9.2 folder from your
    link
    , I
    noticed that there is a more recent version of xulrunner available, v1.9.2.18
    (creation date 22-Jun-2011), but these newer files all have strings like
    '10.04.1' or '10.10.1' in their file names. Maybe only these two Ubuntu
    versions recently needed some changes to xulrunner, which could be the reason
    for the bundled v1.9.2.17 not working for me (as stated above, instead of the
    bundled xulrunner, RSSOwl now falls back to the system's xulrunner v1.9.2.18
    on my box).

    That might mean it's not necessarily a 64bit issue but rather something
    related to Ubuntu's 10.04 release and its respective version of xulrunner.
    When I find some time I could try to confirm this on a (virtual) 32bit install
    of Ubuntu 10.04. That would help, right?

     
  • For 2.1.1 I am planning to improve XULRunner lookup by first finding out if
    the default XULRunner on the OS works and then fallback to the one I ship
    with. That leaves a chance for OS vendors to provide a custom RSSOwl version
    that works for sure. I realize I can probablly not ship 1 XULRunner that works
    on all distributions. I noticed the new XULRunner version but I have not seen
    a 64 Bit version of it yet.

     
  • CB
    CB
    2011-07-26

    Sounds like that might just work (well, at least until I upgrades to Firefox
    4/5 and therefore to xulrunner2, if I understood the previous posts on this
    correctly). Looking forward to testing it. :-)

     
  • So specifically XULRunner 2 is not supported and will not be for a while,
    hence I am bundling 1.9.x.

     
  • looonger
    looonger
    2011-07-28

    @bpasero

    I just wanted you to know that a symbolic link

    ln -s /usr/lib/libhunspell-1.3.so.0 /usr/lib/libhunspell-1.2.so.0

    solves the problem in Arch Linux. Gentoo still uses older version of this
    library that's why rssowl works there out of the box (for now). I found the
    solution here http://aur.archlinux.org/packages.php?ID=1728

    I can use the best rss reader again :)

     
  • RSSOwl 2.1.1 will have a better logic to resolve XULRunner:

    • if path is set, use it
    • if fails or path not set, use bundled xulrunner as path
    • if fails, dont set a path and rely on OS default XULRunner runtime
     
  • A release candidate of 2.1.1 is out including a much beter XULRunner runtime
    detection (see
    http://www.rssowl.org/node/288)

     
  • CB
    CB
    2011-07-29

    For me, this version works fine (Ubuntu 10.04, 64bit). After decompressing the
    archive (to /usr/share/rssowl) I had to correct the subfolder permissions,
    though, because RSSOwl executable couldn't find its 'companion library' or
    something like that and RSSOwl didn't start as only root, not the user, had
    access to the subfolders from the archive.

    Anyway, I can confirm that the 64bit version works, RSSOwl falls back to the
    system's XULRunner (/usr/lib/xulrunner-1.9.2.18). I'm still on Firefox 3.6,
    though, and therefore my system's XULRunner version is 1.9.2.18. So I can't
    speak for those who run FF 4 or 5 and therefore would have XULRunner 2
    installed.

     
  • CB
    CB
    2011-07-29

    Oh, sorry, I forgot: Thank you, bpasero! :-)

     
  • Hm, this 2.1.1 release is not different from the others and I never had to
    change any permissions. What permissions specifically did you change?

     
  • CB
    CB
    2011-07-29

    I didn't before, either, as I installed RSSOwl via the package manager and
    there the permissions were set right -- or possibly corrected already by the
    creator of the .deb file. The 2.1.1 RC, however, I decompressed straight from
    your .zip file.

    I basically had to run the following command from a terminal:

    $ find /usr/share/rssowl/ -type d -exec sudo chmod a+x {} \;

    This would add execute permissions (+x) for all users (a) to all folders and
    subfolders (-type d) below /usr/share/rssowl/, which is necessary to access
    folder contents in the first place.

     
  • Weird, well I will continue to release RSSOwl for Linux as I did in the past,
    no one was having issues I guess so far.

     
  • CB
    CB
    2011-07-29

    I suppose that most people who are willing to install on linux from a .zip
    would know their way around such an issue, so it's no biggy.

    I did extract the archive in some weird way before, that was probably the
    reason. Sorry for the fuzz. When doing it normally right now, all subfolders
    had the correct access permissions set -- well, except for the xulrunner
    subfolder. This one still has 700 permissions for root, the xulrunner folder
    itself and all its subfolders (not the files, though). So if the user does not
    notice and correct this, the bundled xulrunner directory cannot be accessed at
    all by an RSSOwl instance run with user permissions. But again, I guess most
    people would notice that, not much trouble. (And for the GetDeb version of the
    RSSOwl/XULRunner bundle this was corrected, apparently.)

     
<< < 1 2 3 4 > >> (Page 2 of 4)