Problem sharing news in rssowl

Help
Coque
2013-01-01
2013-05-12
  • Coque
    Coque
    2013-01-01

    Hi

    I've used rssowl for about three years without problem and a problem has
    started to appear from 15 days ago. I used to share links in mail and
    external navigator, but now when I share Mail rssowl generates
    error messages like this:

    No se pudo mostrar
    «/usr/lib/rssowl/mailto:?body...on-esto-sentildeores&subject=».
    
    Error: Error al conseguir información para el archivo
    «/usr/lib/rssowl/mailto:?body=Y%20CON%20ESTO%2C%20SE%C3%91ORES%20-%20se%20escrib%C3%ADan%20las%20notas%20musicales%20en%201953%2C%20creada%20por%20Robert%20H.%20Keaton%0Ahttp%3A%2F%2Ffeedproxy.google.com%2F%7Er%2Fcuantarazon%2F%7E3%2F9wyN5rItaWs%2Fy-con-esto-sentildeores&subject=»:
    Nombre de archivo demasiado largo
    Seleccione otro visor e inténtelo de nuevo..
    

    .
    In english:

    Can't show «/usr/lib/rssowl/mailto:?body...on-esto-sentildeores&subject=».
    
    Error: Error when I get information about the file
    «/usr/lib/rssowl/mailto:?body=Y%20CON%20ESTO%2C%20SE%C3%91ORES%20-%20se%20escrib%C3%ADan%20las%20notas%20musicales%20en%201953%2C%20creada%20por%20Robert%20H.%20Keaton%0Ahttp%3A%2F%2Ffeedproxy.google.com%2F%7Er%2Fcuantarazon%2F%7E3%2F9wyN5rItaWs%2Fy-con-esto-sentildeores&subject=»:
    File name too long
    Select another visor and try it again..
    

    .
    And then it's opened the file manager. The similar problem appears when
    I try to open one news on external navigator, but if I try to share in
    facebook, this works fine.

    I recently updated Ubuntu to 12.10 version before the problem appeared,
    but on the firsts days with this new version, Rssowl worked fine.

    I used rssowl 2.1.4 and I updated to 2.1.6 to try to resolv the problem,
    but the problem exits still in 2.1.6.

    Please, could you help me to resolv this problem?

    Thank you very much and happy new year!!!

     
    Last edit: Coque 2013-01-01
  • genodeftest
    genodeftest
    2013-01-04

    Hi
    can you please export a log file http://www.rssowl.org/help#item_5 and post it here or send a PM.

    Does running
    xdg-open "mailto:?body=Y%20CON%20ESTO%2C%20SE%C3%91ORES%20-%20se%20escrib%C3%ADan%20las%20notas%20musicales%20en%201953%2C%20creada%20por%20Robert%20H.%20Keaton%0Ahttp%3A%2F%2Ffeedproxy.google.com%2F%7Er%2Fcuantarazon%2F%7E3%2F9wyN5rItaWs%2Fy-con-esto-sentildeores&subject="
    work with opening your default mail client with some content in the mail window?

     
  • Coque
    Coque
    2013-01-08

    Hi

    First, thank you very much for your help.

    With respect to run the xdg-open command, this works fine.

    I put the log file, but only the last entries of today because the full log is very large:

    !SESSION 2013-01-08 13:43:58.636 -----------------------------------------------
    eclipse.buildId=unknown
    java.version=1.7.0_09
    java.vendor=Oracle Corporation
    BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=es_ES
    Command-line arguments: -os linux -ws gtk -arch x86

    !ENTRY org.rssowl.ui 1 0 2013-01-08 13:44:10.531
    !MESSAGE RSSOwl Starting Up (RSSOwl/2.1.6.201212081831 (X11; U; en))

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:28.239
    !MESSAGE NLS unused message: Shortcuts_shortcutTab in: org.eclipse.ui.internal.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:28.240
    !MESSAGE NLS unused message: Shortcuts_selectShortcutsLabel in: org.eclipse.ui.internal.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:28.240
    !MESSAGE NLS unused message: Shortcuts_availableMenus in: org.eclipse.ui.internal.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:28.240
    !MESSAGE NLS unused message: Shortcuts_availableCategories in: org.eclipse.ui.internal.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:28.240
    !MESSAGE NLS unused message: Shortcuts_allShortcuts in: org.eclipse.ui.internal.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:28.240
    !MESSAGE NLS unused message: Util_listNull in: org.eclipse.ui.internal.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:28.240
    !MESSAGE NLS unused message: OpenBrowserHandler_NoInfoDialogMessage in: org.eclipse.ui.internal.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:28.240
    !MESSAGE NLS unused message: OpenBrowserHandler_NoInfoDialogTitle in: org.eclipse.ui.internal.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:28.240
    !MESSAGE NLS unused message: AboutFeaturesDialog_SimpleTitle in: org.eclipse.ui.internal.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:28.240
    !MESSAGE NLS unused message: ProblemCyclicDependency in: org.eclipse.ui.internal.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:29.954
    !MESSAGE NLS unused message: InternalError in: org.eclipse.ui.internal.progress.messages

    !ENTRY org.eclipse.osgi 2 1 2013-01-08 13:44:41.078
    !MESSAGE NLS unused message: CoreUtils_UNNABLE_CONNECT in: org.rssowl.core.util.messages

     
  • genodeftest
    genodeftest
    2013-01-09

    Ok, there should be some kind of stack trace looking like this:

    Exception in thread "main" java.lang.NullPointerException
         at org.rssowl.ui.something (Foo.java:20)
         at org.rssowl.ui.something (Foo.java:20)
         at org.rssowl.ui.something.else (Foo.java:20)
         at org.rssowl.ui.something2.else.something (Foo.java:20)
         at org.rssowl.core.something (Foo.java:20)
         at org.rssowl.core.something.nothing (Foo.java:20)
         at org.rssowl.ui.something (Foo.java:20)
         at org.rssowl.ui.something (Foo.java:20)
    

    (with different line numbers and different paths, but about 10 to 100 lines like this)
    Can you please locate that one and post it here?

     
  • Coque
    Coque
    2013-01-10

    In my log it doesn't appear any stack trace in the last days. They appear in entries from some months ago and they looks refer to other problem like "no free available space in device" when I was downloading some files.

    Also, I've searched for this stack trace in other logs like .xsession_error, /var/log/syslog, /var/log/messages. etc but I haven't found nothing.

     
  • Coque
    Coque
    2013-01-13

    I've just tried to change the java engine from openjdk 1.7.0 to openjdk 1.6.0 and also to sun 1.6.0, but this doesn't fix the problem

     
  • genodeftest
    genodeftest
    2013-01-14

    It is a problem calling xdg-open (or some similar tool) which will never give a stack trace since the java code does not recieve any exception.

     
  • Coque
    Coque
    2013-01-15

    I've just tried to change the default file manager and I've checked that it isn't the problem. I've looked for the commands in "ps aux" and anyway the parameter which it's passed by rssowl is prefixed with "/usr/lib/rssowl/". IMHO, the problem is Rssowl passes the prefix "/usr/lib/rssowl/" in the parameter string instead of passing only the rest of string.

    For example, if I stay in a news with url: "http://mynews.com/1234" and I click on button "Open in external browser", rssowl will pass the string "/usr/lib/rssowl/http://mynews.com/1234" instead of passing only "http://mynews.com/1234". So the correspondient command will fail.

    If I click on "share mail", rssowl will pass "/usr/lib/rssowl/mailto:?BODY=http%3A%2F%2Fmynews.com%2F1234&SUBJECT=test_news...." instead of passing only the string "mailto:?BODY=http%3A%2F%2Fmynews.com%2F1234&SUBJECT=test_news...."

    I think the problem is some change in rssowl configuration or how rssowl pass the url parameter to external applications.

     
  • Coque
    Coque
    2013-04-22

    I've just discovered that the problem is how RssOwl passes the external url to xdg-open. The external url is incorrect.

    For any reason, RssOwl put the working directory in front of external url and because of this, xdg-open allways open the external url (both http or mailto) with file explorer (nautilus) instead of use the internet browser (firefox) or the mail client (thunderbird).

    I've run RssOwl from different directories and the url which rssowl passes to xdg-open is the actual working directory joined to real url. For example, let's supposing that I want to open the url "http://mynews.com/1234" in external browser. If I run rssowl from /home/user directory:

    [/home/user]$ /usr/lib/rssowl/RSSOwl
    

    when I try to open that news in external browser, it returns "/home/user/http://mynews.com/1234"

    If I run rssowl from /tmp directory:

    [/tmp]$ /usr/lib/rssowl/RSSOwl
    

    when I try to open that news in external browser, it returns "/tmp/http://mynews.com/1234"

    With "mailto" urls happens the similar process.

    So the problem is how rssowl build the url which it returns.

    I don't know if I have any library corrupted, but I updated rssowl from 2.1.4 to 2.1.6, but it didn't resolved the problem.

    Anybody can help me?

     
  • Coque
    Coque
    2013-05-12

    Hi

    I've tested your workaround, but it hasn't worked.

    Anyway, I don't know if I'd done well. I don't know where is the "plugins" folder. I've copied the .jar file in "/usr/lib/rssowl/plugins/", then I've renamed it into "org.rssowl.ui_2.1.6.201212081831.jar". Is it correct?

    I had Rssowl 2.1.6 already, anyway must I download again from https://sourceforge.net/projects/rssowl/files/rssowl%202/2.1.6/?

    Also rssowl has a new problem with the workaround because with internal browser do not show the images of the new news and if I open the news in a new tab, I get the next error:

    "Unable to load page

    Problem occurred while loading the URL http://feeds.weblogssl.com/~r/xataka2/~3/GFb6QA3gLmE/seesv-s205-la-singular-camara-que-indica-de-donde-sale-un-sonido
    Cannot resolve hostname (feeds.weblogssl.com)

    Try again
    "

    If I configure external browser, rssowl always return errors as the previous posts in this issue.

    If I undo the changes and I restore the original "org.rssowl.ui_2.1.6.201212081831.jar", rssowl shows the news well again with the internal browser. But the original problem also goes on appearing, of course.

    Please, you note that the problem appears not only when I want to open a news on external browser. It also appears when I want to send the url of news in a mail (share to email).

    Thanks

     
    Last edit: Coque 2013-05-12