Won't Run From Menu

Help
2005-05-13
2012-08-29
  • Running Mandrake 10.1 with KDE 3.2. Runs fine from terminal (# rssowl), but when I try to run it from the menu, it just sits in the taskbar and fades away. Tried all sorts of different commands and renaming of files, but nothing seems to work. I've had it working on previous installs, but for some reason, can't get it to work this time around. Any help would be appreciated.

     
    • I assume you are using the RPMs of RSSOwl 1.1?

      Ben

       
    • I've tried using both the RPMs and the binary, in addition to older versions of both. I spent a good 10 hours yesterday installing my system from scratch and several of those hours were spent trying to get RSSOwl to a) work in general and b) work from either the menu or "quicklaunch' bar.

       
      • Hm. So what is the command you are executing from the Menu? It should be something like:

        "java -Djava.library.path=<SWT> -jar rssowl.jar"

        Whereas <SWT> is the directory where the *.so files are in. These come with the binary version of RSSOwl.

        Hope that helps,
        Ben

         
    • I have tried that and a slew of other permutations of that ("cd /usr/share/rssowl; java -jar -Djava.library.path=<SWT> rssowl.jar" "/usr/bin/rssowl" "java -jar -Djava.library.path=<SWT> rssowl.jar" "rssowl" "sh rssowl.sh" "rssowl.sh" "java -jar -Djava.library.path=<SWT> /usr/share/rssowl") Like I said, I can get it to run fine within terminal ("rssowl"), but once I close the terminal window, so does RSSowl. (Yes, I tried checking 'run in terminal' on all of the above permutations, but to no avail; it closes with and error of 127) I love the program, but I'm at about my wit's end on this one.

       
      • Did you try to append a "&" to the executed command in order to have it run seperatly from the Shell, so that it is not quit after you close the Shell?

        Ben

         
    • "rsswol&" and "rssowl &" both run the program, but again, close upon closing the shell.