RSSOwl2 Ubuntu Feisty issues

Help
2007-09-12
2012-08-29
  • Hello,
    I cannot seem to run RSSOwl2 on Ubuntu feisty.

    I have tried installing Eclipse 3.3 and installing RSSOwl that way, but I am unable to do so due to issues with Eclipse 3.3 (Ubuntu repository only supports up to 3.2).

    I have tried downloading the RSSOwl for Linux32 and running it without going through Eclipse. Unfortunately, this generates an error whenever I try to start the program. The error messages are in a file, ~/.rssowl2M6Config/1189611809980.log

    The contents of the file are as follows:

    !SESSION 2007-09-12 11:43:19.094 -----------------------------------------------
    eclipse.buildId=unknown
    java.fullversion=GNU libgcj 4.1.2 (Ubuntu 4.1.2-0ubuntu5)
    BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
    Command-line arguments: -os linux -ws gtk -arch x86

    !ENTRY org.eclipse.osgi 4 0 2007-09-12 11:43:33.333
    !MESSAGE An error occurred while automatically activating bundle org.eclipse.equinox.app (34).
    !STACK 0
    org.osgi.framework.BundleException: Exception in org.eclipse.equinox.internal.app.Activator.start() of bundle org.eclipse.equinox.app.
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1018)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
    at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400)
    at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
    at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:417)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340)
    at org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(SingleSourcePackage.java:37)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:405)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
    at java.lang.ClassLoader.loadClass(libgcj.so.70)
    at org.eclipse.core.internal.runtime.PlatformActivator.startAppContainer(PlatformActivator.java:47)
    at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:32)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999)
    at java.security.AccessController.doPrivileged(libgcj.so.70)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)
    Caused by: java.lang.NoClassDefFoundError: org.eclipse.equinox.internal.app.AppPersistence
    at java.lang.Class.initializeClass(libgcj.so.70)
    at org.eclipse.equinox.internal.app.Activator.start(Activator.java:54)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999)
    at java.security.AccessController.doPrivileged(libgcj.so.70)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993)
    ...29 more
    Caused by: java.lang.ClassNotFoundException: org.eclipse.equinox.internal.app.EclipseScheduledApplication
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:434)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
    at java.lang.ClassLoader.loadClass(libgcj.so.70)
    at java.lang.Class.forName(libgcj.so.70)
    at java.lang.Class.initializeClass(libgcj.so.70)
    ...33 more
    Root exception:
    java.lang.NoClassDefFoundError: org.eclipse.equinox.internal.app.AppPersistence
    at java.lang.Class.initializeClass(libgcj.so.70)
    at org.eclipse.equinox.internal.app.Activator.start(Activator.java:54)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999)
    at java.security.AccessController.doPrivileged(libgcj.so.70)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:260)
    at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:400)
    at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:111)
    at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:417)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:189)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:340)
    at org.eclipse.osgi.framework.internal.core.SingleSourcePackage.loadClass(SingleSourcePackage.java:37)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:405)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
    at java.lang.ClassLoader.loadClass(libgcj.so.70)
    at org.eclipse.core.internal.runtime.PlatformActivator.startAppContainer(PlatformActivator.java:47)
    at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:32)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999)
    at java.security.AccessController.doPrivileged(libgcj.so.70)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)
    Caused by: java.lang.ClassNotFoundException: org.eclipse.equinox.internal.app.EclipseScheduledApplication
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:434)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
    at java.lang.ClassLoader.loadClass(libgcj.so.70)
    at java.lang.Class.forName(libgcj.so.70)
    at java.lang.Class.initializeClass(libgcj.so.70)
    ...33 more

    !ENTRY org.eclipse.core.runtime 4 0 2007-09-12 11:43:33.527
    !MESSAGE
    !STACK 0
    org.osgi.framework.BundleException: Exception in org.eclipse.core.internal.runtime.PlatformActivator.start() of bundle org.eclipse.core.runtime.
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:1018)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)
    Caused by: java.lang.NoClassDefFoundError: org.eclipse.equinox.internal.app.CommandLineArgs
    at org.eclipse.core.internal.runtime.PlatformActivator.startAppContainer(PlatformActivator.java:47)
    at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:32)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999)
    at java.security.AccessController.doPrivileged(libgcj.so.70)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993)
    ...10 more
    Root exception:
    java.lang.NoClassDefFoundError: org.eclipse.equinox.internal.app.CommandLineArgs
    at org.eclipse.core.internal.runtime.PlatformActivator.startAppContainer(PlatformActivator.java:47)
    at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:32)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999)
    at java.security.AccessController.doPrivileged(libgcj.so.70)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)

    !ENTRY org.eclipse.osgi 4 0 2007-09-12 11:43:33.537
    !MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.3.100.v20070530.jar/ [3] is not active.

    !ENTRY org.eclipse.osgi 4 0 2007-09-12 11:43:33.549
    !MESSAGE Application error
    !STACK 1
    java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:72)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:363)
    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
    at java.lang.reflect.Method.invoke(libgcj.so.70)
    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:504)
    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:443)
    at org.eclipse.equinox.launcher.Main.run(Main.java:1169)
    at org.eclipse.equinox.launcher.Main.main(Main.java:1144)

    !ENTRY org.eclipse.osgi 2 0 2007-09-12 11:43:33.605
    !MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
    !SUBENTRY 1 org.eclipse.osgi 2 0 2007-09-12 11:43:33.607
    !MESSAGE Bundle update@plugins/org.rssowl.lib.jdom_2.0.0.200706070038.jar [9] was not resolved.
    !SUBENTRY 2 org.rssowl.lib.jdom 2 0 2007-09-12 11:43:33.607
    !MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: J2SE-1.5
    !SUBENTRY 1 org.eclipse.osgi 2 0 2007-09-12 11:43:33.607
    !MESSAGE Bundle update@plugins/org.rssowl.lib.lucene_2.0.0.200706070038/ [18] was not resolved.
    !SUBENTRY 2 org.rssowl.lib.lucene 2 0 2007-09-12 11:43:33.607
    !MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: J2SE-1.5
    !SUBENTRY 1 org.eclipse.osgi 2 0 2007-09-12 11:43:33.607
    !MESSAGE Bundle update@plugins/org.rssowl.ui_2.0.0.200706070038.jar [31] was not resolved.
    !SUBENTRY 2 org.rssowl.ui 2 0 2007-09-12 11:43:33.607
    !MESSAGE Missing required bundle org.rssowl.core_0.0.0.
    !SUBENTRY 1 org.eclipse.osgi 2 0 2007-09-12 11:43:33.607
    !MESSAGE Bundle update@plugins/org.rssowl.core_2.0.0.200706070038.jar [41] was not resolved.
    !SUBENTRY 2 org.rssowl.core 2 0 2007-09-12 11:43:33.607
    !MESSAGE Missing required bundle org.rssowl.lib.jdom_0.0.0.
    !SUBENTRY 2 org.rssowl.core 2 0 2007-09-12 11:43:33.607
    !MESSAGE Missing required bundle org.rssowl.lib.lucene_0.0.0.

    Any help would be appreciated.
    Email to fyre at fyreplace dot com (or, if using a yahoo email address, escalf at the same domain)

    Thanks.
    -Eric

     
    • Sounds like you are running the gcj as default. To configure J2SE as the default JVM:

      sudo update-alternatives --config java

      Then choose the option that corresponds to J2SE.