External Browser - Open Link - Keep Focus

2011-10-30
2012-09-21
  • Jim Zippeltoff
    Jim Zippeltoff
    2011-10-30

    Hi,

    I just tried RSS Owl and I really like its features and interface a lot. Sadly
    there is a one total showstopper for me which forces me to stay with my old
    RSS Feedreader (Feedreader 3:
    http://www.feedreader.com/ ), which still seems
    to be the only reader providing me this feature.

    Feature request: simple preference option which would force the RSS Owl to
    keep focus when opening links to an external browser.

    It is for sure far more efficient first go through all my feeds and click them
    open and after that read them through. Changing the focus every time you open
    a link is unbearable when you have to do this hundreds of times daily and
    makes the process of going through the feeds way to slow.

    This feature can be done on the RSS Feeder side because Feedreader 3 for
    example can provide this option as "Keep application in front when opening
    links in browser" and it really works as it should.

    What I have learned is that with Firefox you can gain this feature by tweaking
    Firefox itself to stay on background. This feature is not available on my
    preferred browser thou. On top of that, the Firefox feature wouldn't be
    perfect either, because it would change the behaviour for any external program
    launching urls, not just RSS Owl.

    see: http://sourceforge.net/projects/rssowl/forums/forum/296910/topic/4651581
    ?message=10586982

    Obviously I am not the only one who would like to have this feature. Don't
    know how important this is for other people, but for me its a dealbreaker :(

    see:

    http://sourceforge.net/projects/rssowl/forums/forum/296910/topic/4651581?mess
    age=10586965

    http://sourceforge.net/projects/rssowl/forums/forum/296910/topic/3049800?mess
    age=6556271

    http://sourceforge.net/projects/rssowl/forums/forum/296909/topic/1796900

    anyway, thanks for making this great open source rss feeder, I hope some day I
    can start using :)

    br,

    Jimmy

     
  • P Cause
    P Cause
    2011-11-01

    After you do the exec to launch if you delay and then make a call to set focus
    to your window would that work?

     
  • Jim Zippeltoff
    Jim Zippeltoff
    2011-11-02

    That -noraise command line option would've been an easy solution.
    Unfortunately that option is only for *nix OS's.

    http://www.opera.com/docs/switches/

    Of course there might be some per browser based solution for this issue, but I
    was thinking of contributing an idea which would be universal solution on rss
    owl side, no matter what browser you use.

    Personally I'd change to rss owl if I got Opera working like this, it would be
    enough for me.

    When I watched feedreader more carefully, it seems that it doesn't keep itself
    on top, but actually the opera taskbar tab gets focus for a millisecond or so,
    but then it instantly gets back to feedreader.

    So infact feedreader seems to grab the focus very fast back to itself and when
    I looked it even more carefully, actually the browser windows flashes itself
    on top of feedreader for a brief moment, but so quick that it doesn't bother
    me.

    This means that feedreader option just takes the focus back to itself after it
    has changed to the browser window?

    I don't know much about coding, but I'd guess taking the focus back wouldn't
    be very hard to accomplish?

     
  • Mark McNeill
    Mark McNeill
    2011-11-07

    I've found a useful workaround, using Chromium in Gnome 2.3: have the browser
    in a different workspace.

     
  • Silion
    Silion
    2012-09-21

    I created autohotkey script that fixes this issue, it works with all browsers.
    What you need:
    -autohotkey (I use autohotkey_L x64 but it should work with other versions too)
    -change .ahk files default program to autohotkey
    -either put the script in autostart, or make it run with RSSOwl
    Sometimes windows refuses to run autohotkey scripts on startup so use task scheduler if that happens

    Script only tiggers when you use enter or return key, mouse keys are unaffected but can be easly added.

     
    Last edit: Silion 2012-09-22