RSS Bandit fails to start

2010-08-14
2012-09-23
  • I use windows 7 x64 and RSS Bandit v1.9.0.1002
    i click on the program icon, and nothing happens
    i looked into process explorer, RSS bandit starts, second later the process
    closes itself

     
  • Is this a upgrade installation (newer version of RSS Bandit installed over an
    yet existing older one)?
    Did you use a upgraded Windows 7 (e.g. from Vista) or a "fresh" installation?
    What kind of Windows 7 (Home, ...)?

    Can you please check these things on your machine:
    1. Is there a folder (created) like this: C:\Users\<YOUR_WINDOWS_ACCOUNT>\AppData\Local\RssBandit ?
    2. Is there a folder (created) like this: C:\Users\<YOUR_WINDOWS_ACCOUNT>\AppData\Roaming\RssBandit?
    3. Did you get a firewall warning notice at startup (about to allow access of our update-info web service)?

    Thanks for reporting that issue!

     
  • thanks for reply
    sorry for incomplete info

    • windows 7 ultimate, fresh installation
    • .net framework 3.5 is installed
    • both folders exist
    • I added a rule for RSSbandit (always allow to access Internet)
     
  • There are also file(s) within the folder(s)?
    Any entry in the application event log (windows event log)?

    I have here the same config (Dell Laptop, Win7 Ultimate 64 bit) and it runs
    fine !?

     
  • yes, there are files
    there are no entries in windows event log regarding RSS Bandit
    i will try to reinstall (omg, again) and post here

     
  • ok, i've done it
    and i found trace.log file in 'Roaming' folder (mentioned above)

    2010-08-16 17:35:14,478 DEBUG RssBandit.WinGui.Utility.Settings - Settings:
    There was an error while deserializing from Settings Storage. Ignoring.
    2010-08-16 17:35:14,522 DEBUG RssBandit.WinGui.Utility.Settings - Settings:
    The exception was:
    Exception: System.IO.FileNotFoundException
    Message: Nie można odnaleźć pliku
    'C:\Users\BMC\AppData\Roaming\RssBandit.settings2.xml'.
    Source: mscorlib
    w System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    w System.IO.FileStream.Init(String path, FileMode mode, FileAccess access,
    Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize,
    FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean
    bFromProxy)
    w System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access,
    FileShare share, Int32 bufferSize)
    w NewsComponents.Utils.FileHelper.OpenForRead(String fileName)
    w RssBandit.WinGui.Utility.Settings.Deserialize()

    translation:
    Nie można odnaleźć pliku = Cannot find a file

    I don't understand. Why there should be '.settings2.xml' in 'Roaming' folder,
    when i installed it again? Shouldn't RSS Bandit create it itself?

     
  • Yes, that log output is just reported for debugging and you can ignore that.
    No other entries in the .log?

    OK; lets go on step by step:

    Do you have a file named "feedsources.xml" and possibly a
    "DirectAccess.xxxxx.subscription" file in your roaming\RssBandit folder? If
    so, they are empty?

     
  • Same thing happening to me. Rssbandit started once. When I exited, now it
    won't restart. Same conditions as what is listed in this post. Is there a
    remedy?

     
  • Is any of the files above there, but empty (no content)?

     
  • Same issue here ... also Win7 x64. But it worked on a different Win7 x64 box
    :S

     
  • I have tried several earlier versions and none worked. Trace.log is created
    but empty.

     
  • Misteriously it worked one day in the very same computer that was previously
    not working (no Windows reinstallation or similar, maybe a Windows Update
    patch) and configured Google Reader synchronization and start working with it.
    Now it has stopped working again, no error, just launches the process and
    silently dies.
    I do have feedsources.xml and DirectAccess.XXXXX.subscription files, neither
    of those empty.

     
  • i met the same question