#787 Incorrect CultureInfo causes SandDock to not load

v1.3.0.42
closed
5
2012-09-23
2006-08-01
Anonymous
No

In WinGUIMain.cs:

The workaround in the source code for cultures does
not work if the English United States regional
settings have been customized.

The customizations were:
The digit grouping symbol changed from comma to
space.
List seperator changed from comma to space.
Negative currency format changed to $-1.1
Time format changed to HH:mm:ss
* Date format changed to yyyy-MM-dd

Proposted fix:
The following fix has been tested and it does fix the
bug on the system which experience the problem.

Change:

// workaround the issue described here:
http://www.divil.co.uk/net/support/kb/article.aspx?
id=14
using (new CultureChanger("en-US")) {

To:

// workaround the issue described here:
http://www.divil.co.uk/net/support/kb/article.aspx?
id=14
using (new CultureChanger("")) {

This occurs in 3 places in that file.

I have attached the patched file for version 1.3.0.38.
It is in a zip file.

Explanation of fix:
Changing "en-US" to "" changes the culture to the
invarient culture which does not use the customized
settings.
On the computer for which the bug was occuring, the en-
US culture was customized but the invariant culture is
not customizable.

My name: Emil
My email: squatx@gmail.com

Discussion

  • Patched file for version 1.3.0.38. Unzip it.

     
    Attachments
  • Logged In: NO

    Sorry, I posted the same bug twice.

     
  • Logged In: YES
    user_id=714452

    Thanks for the patch/suggestions. I adopted the solution
    for that issue to the current code base.

     
  • Logged In: NO

    Thank you!