About a month ago, I requested some help in getting rosegarden to compile.  It was suggested by one person that my build environment is weird.  He did not know of a solution, and suggested that I wait for someone more knowledgeable to get back from vacation.  Another person later suggested that I give up building from source, and install from rpm.  After looking around for rpms of rosegarden, I determined that the only rpms available are old versions.  I am anxious to use the latest version.  That means tracking down and fixing the flaws in my build environment that result in this error.  To my knowledge, it is unable to link to libraries that are generated in an earlier step of the build script. 
 
Can anyone suggest where I can look to fix this problem?  While I have not tried to compile the most recent version, I suspect that this problem will be replicated there as well.  I want to get the version I have already downloaded to compile, before I download and compile the latest version.  Any ideas will be greatly appreciated.
 
Darcy
-----Original Message-----
From: Darcy Kahle [mailto:darcykahle@sympatico.ca]
Sent: Wednesday, September 13, 2006 5:54 PM
To: rosegarden-user@lists.sourceforge.net
Subject: RE: [Rosegarden-user] Help needed compiling rosegarden 1.2.4

I received the following response from D. Michael McIntyre on the Dev mail list, in which he indicates that my build environment is "weird".  I would appreciate any ideas that anyone can provide me to track down the flaw in my build system, and correct it, so that I can get this to compile.  I have not been able to track down any hints through google, and I am anxious to get this working.  I have also tried to compile the new RC version, and I am getting the same errors, and required to add the extra #include statements to even reach the link stage.
 
Any ideas?
 
Darcy Kahle
url: www.kahleinfotech.com
 
--------------------------------------------------------
 
From: D. Michael McIntyre <rosegarden.trumpeter@gm...>
Re: FW: Help needed compiling rosegarden 1.2.4  
2006-08-29 07:06
 On Monday 28 August 2006 10:08 pm, Darcy Kahle wrote:
 > On Friday, August 25th, 2006, I sent this email to the Rosegarden user
 > list. I have not yet received a response, and I think that the devel list
 > might be more applicable.  Could someone please let me know what I can do
 > to fix this problem?
 
 Just so you don't think you're shouting in a vacuum, I did read this question 
 on the user list.  I just don't have anything in particular to offer.  The 
 problem you had with having to add missing includes suggests you have a weird 
 build environment, but what that means for this other bit, or how you need to 
 hack around it, I really haven't a clue.  The build system isn't my strong 
 suit, and I haven't ever used any flavor of Red Hat.  I've got nothing to go 
 on, and I'm afraid you're stuck waiting for someone with more of a clue to 
 get back from vacation.
 
 Sorry about that, and best of luck!
 
 -- 
 D. Michael 'Silvan' McIntyre  ----   Silvan <dmmcintyr@us...>
 Linux fanatic, and certified Geek;  registered Linux user #243621
 
 Author of Rosegarden Companion http://rosegarden.sourceforge.net/tutorial/
 
-----Original Message-----
From: rosegarden-user-bounces@lists.sourceforge.net [mailto:rosegarden-user-bounces@lists.sourceforge.net]On Behalf Of Darcy Kahle
Sent: Friday, August 25, 2006 10:59 AM
To: rosegarden-user@lists.sourceforge.net
Subject: [Rosegarden-user] Help needed compiling rosegarden 1.2.4

I am currently trying to upgrade from Rosegarden-4 0.9.8 to the new Rosegarden 1.2.4 on a Whitebox Enterprise Linux 3.0 computer (for those of you unaware, WBEL 3.0 is equivalent to RedHat Enterprise Linux 3.0 - the redhat source was respun).  I have encountered problems, and have solved most of them.  At this point, though, I am stuck.
 
One problem that I found and solved was that the files gui/audiopluginmanager.cpp, gui/rosegardengui.cpp, gui/startuptester.cpp, gui/audiopreviewthread.cpp, and gui/audiopluginoscgui.cpp all were missing the line "#include <unistd.h>".  As a result, the compiler had a problem with the usleep() function that is used in these files.  After adding that line to those files, I came to my current problem.
 
I am at the point where sequencer/rosegardensequencer is being linked.  The linker is giving a "undefined reference" error for Rosegarden::SoundDriverFactory::CreateDriver() function.  I am at a loss to fix this.  Here is what the linker spit out, so that someone can see something that I cannot see.
 
======
g++ -Wl,--rpath=/usr/lib/qt-3.3/lib -Wl,--rpath=/usr/lib -Wl,--rpath=/usr/lib/kde3 -lasound -lm -ldl -lpthread -L/usr/local/lib -ljack -llo -L/usr/X11R6/lib -lXft -lX11 -lfreetype -lXrender -lfontconfig -llrdf -o RGbuild/sequencer/rosegardensequencer RGbuild/sequencer/mmappedcontrolblock.o RGbuild/sequencer/mmappedsegment.o RGbuild/sequencer/rosegardensequencer.o RGbuild/sequencer/main.o RGbuild/sequencer/sequencermapper.o RGbuild/sequencer/rosegardensequenceriface_skel.o -LRGbuild/base -Lbase -LRGbuild/sound -Lsound -L/usr/lib -L/usr/lib/qt-3.3/lib -lqt-mt -lRosegardenSequencer -lRosegardenSound -lbase -lkdeui -lkdecore
RGbuild/sequencer/rosegardensequencer.o(.text+0x3a1): In function `RosegardenSequencerApp::RosegardenSequencerApp()':
: undefined reference to `Rosegarden::SoundDriverFactory::createDriver(Rosegarden::MappedStudio*)'
RGbuild/sequencer/rosegardensequencer.o(.text+0xb4e): In function `RosegardenSequencerApp::RosegardenSequencerApp()':
: undefined reference to `Rosegarden::SoundDriverFactory::createDriver(Rosegarden::MappedStudio*)'
RGbuild/sequencer/rosegardensequencer.o(.text+0x19c5): In function `RosegardenSequencerApp::startPlaying()':
: undefined reference to `Rosegarden::SoundDriver::initialiseAudioQueue(std::vector<Rosegarden::MappedEvent, std::allocator<Rosegarden::MappedEvent> > const&)'
RGbuild/sequencer/rosegardensequencer.o(.text+0x5f3a): In function `RosegardenSequencerApp::rationalisePlayingAudio()':
: undefined reference to `Rosegarden::SoundDriver::initialiseAudioQueue(std::vector<Rosegarden::MappedEvent, std::allocator<Rosegarden::MappedEvent> > const&)'
collect2: ld returned 1 exit status
scons: *** [RGbuild/sequencer/rosegardensequencer] Error 1
scons: building terminated because of errors.
 
======
 
Thanks for any help that you can provide.
 
Darcy
url: www.kahleinfotech.com