#23 news gps receiver support

open
nobody
None
5
2007-01-28
2007-01-27
munna82
No

version 0.16 for mac does not support the following gps device

GlobalSat BU-353 Water-Proof USB Mouse GPS Receiver - SiRF Star III

http://www.buygpsnow.com/globalsat-bu-353-water-proof-usb-mouse-gps-receiver-sirf-star-iii-bu353-mac-osx-compatible-waas-enabled-bu353-bu-353-globalsat-g-mouse-self-contained-and-waterproof-super-cohesive-magnetic-for-mounting-on-the-car-usb-interface-connection-455.aspx

this has a usb to serial driver provided by the manufacturer.

Discussion

  • Richard Lynch
    Richard Lynch
    2007-01-27

    • status: open --> pending
     
  • Richard Lynch
    Richard Lynch
    2007-01-27

    Logged In: YES
    user_id=1108678
    Originator: NO

    Could you please see if it works with Roadnav 0.17.

     
  • munna82
    munna82
    2007-01-27

    Logged In: YES
    user_id=1699728
    Originator: YES

    Roadnav 0.17 for mac crashes on startup. It wont open on my intel mac. I have tried opening using rosetta too. So, i am not sure whether the GPS device would work or not.

     
  • munna82
    munna82
    2007-01-27

    • status: pending --> open
     
  • Richard Lynch
    Richard Lynch
    2007-01-27

    Logged In: YES
    user_id=1108678
    Originator: NO

    Try deleting all of Roadnav's data files in ~/Library/Application Support/roadnavdata and see if that resolves the problem with 0.17.

     
  • Richard Lynch
    Richard Lynch
    2007-01-27

    • status: open --> pending
     
  • munna82
    munna82
    2007-01-28

    Logged In: YES
    user_id=1699728
    Originator: YES

    Deleting the library files worked, but once launched, the application almost freezes my system (mouse movement is verrrrrrrry slow with a lag of about 30 seconds and the mouse moves once every minute)

     
  • munna82
    munna82
    2007-01-28

    • status: pending --> open
     
  • Richard Lynch
    Richard Lynch
    2007-01-28

    • status: open --> pending
     
  • Richard Lynch
    Richard Lynch
    2007-01-28

    Logged In: YES
    user_id=1108678
    Originator: NO

    Try today's build of Roadnav 0.17 .. does it work any better?

     
  • munna82
    munna82
    2007-01-28

    Logged In: YES
    user_id=1699728
    Originator: YES

    The same thing happens with todays bild too.

     
  • munna82
    munna82
    2007-01-28

    • status: pending --> open
     
  • Richard Lynch
    Richard Lynch
    2007-01-28

    Logged In: YES
    user_id=1108678
    Originator: NO

    Does it freeze your system when you try to download certain states/counties, or when it's just downloading the basemaps of the US? If it's when you download certain states/counties, which ones are you downloading?

     
  • munna82
    munna82
    2007-01-28

    Logged In: YES
    user_id=1699728
    Originator: YES

    it does not freeze during downloads, but after the download is complete

     
  • Richard Lynch
    Richard Lynch
    2007-01-28

    Logged In: YES
    user_id=1108678
    Originator: NO

    Right, but which downloads?

     
  • munna82
    munna82
    2007-01-28

    Logged In: YES
    user_id=1699728
    Originator: YES

    The initial downloads that are done when the application is launched for the first time. I am clearing the library folder before I launch it. Also, it freezes when I connect the
    GPS unit. Otherwise it is fine.

     
  • Richard Lynch
    Richard Lynch
    2007-01-30

    Logged In: YES
    user_id=1108678
    Originator: NO

    Alright, I posted a new copy of Roadnav 0.17 linked against wxWidgets 2.6.3 instead of 2.8.0. Try clearing the roadnavdata folder and seeing if it behaves any differently.

     
  • munna82
    munna82
    2007-01-30

    Logged In: YES
    user_id=1699728
    Originator: YES

    It happens with the new copy that is posted too.

     
  • M^3
    M^3
    2007-03-05

    Logged In: YES
    user_id=997697
    Originator: NO

    I tried my Holux gr-213u on a Macbook Pro and was not able to use the driver the manufacturer supplied, but an open source driver (I believe it was this one - http://sourceforge.net/project/showfiles.php?group_id=157692 ) made it work. Unfortunately it would lose connection after 10-15 seconds. I think this disconnection is a separate issue, either w/ roadnav or my GPS unit. I have a similar problem on a laptop running ubuntu 6.10 and the same version of roadnav (.17) if I can prove it is roadnav and not my GPS unit, I will file a bug report for it.