Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

rioutil 1.5.0b almost compiles on kernel 2.6

Emmanuel
2005-04-17
2013-04-23
  • Emmanuel
    Emmanuel
    2005-04-17

    On of the problems is that appearantly, kernel 2.6 doesn't have .st_mtimespec on the stat structure. I got around it by using .st_mtime instead. So I changed:
    mp3->mod_date  = statinfo.st_mtimespec.tv_sec;
    to:
    mp3->mod_date  = statinfo.st_mtime;
    in the file librioutil/mp3.c. But, although it compiled, I don't know if it works because I ran into an error I wasn't able to solve.

    driver_libusb.o~ranlib: No such file or directory
    make: *** [librioutil.la] Error 1
    This seems to be an error in a config file or something. I looked through the Makefile, but couldn't find anything. I also tried using #ifdef or something to compile the st_mtime thing about depending of the kernel, but I don't know how to do that.

     
    • Ike Stoddard
      Ike Stoddard
      2005-04-18

      Apparently some support files are mismatched. I moved all the libtool stuff to a subdirectory for safekeeping.

      Your clue, and it took me a good long time stare to see it, is that "ranlib" starts another command in the Makefile. I found I actually was several revs behind in the autotools, so I updated my suite. Then, I copied "missing" and "ltmain.sh" from my aclocal installation, and then did aclocal/automake/autoconf to clean up. Then configure could generate Makefiles that ran.

      Now I have a compiled rioutil, but the Cali has left the house until Sunday, so I can't test it yet.

       
    • Daniel Black
      Daniel Black
      2005-04-22

      I just added a patch fixing both of these bugs in the bugs section.

       
      • Matt Kenworthy
        Matt Kenworthy
        2005-07-17

        Hi Dan,

        I've looked for your patch in the "Bugs" section and a couple of other pleace, but I can't find them. Your email bounces, so I apologize for mucking up the forum like this...

        Could you post the patch to this thread, or put it in some other public place and provide a link to it?

        Many thanks,

        Matt