Suggestions & Ideas

Dan Dediu
2010-06-19
2014-08-12
<< < 1 2 (Page 2 of 2)
  • mdowle
    mdowle
    2012-08-14

    Hi.  I really like the gedit with R on Linux,  thanks for the plugin.

    I've been trying to setup F8 to execute the current line (if no code is highlighted), but if code is highlighted then execute that selection.  Is that possible?   It's how Notepad++ with the NppToR add-on works on Windows.  It's really convenience to have a single key press to do that,  if for example stepping through code.

    In the rgedit configure box I've tried setting both the top left values to F8.  Running the current line works, but not running the selection (if any).

     
  • Dan Dediu
    Dan Dediu
    2012-08-14

    Hi Matthew,

    quote] I've been trying to setup F8 to execute the current line (if no code is highlighted), but if code is highlighted then execute that selection. Is that possible? It's how Notepad++ with the NppToR add-on works on Windows. It's really convenience to have a single key press to do that, if for example stepping through code. In the rgedit configure box I've tried setting both the top left values to F8. Running the current line works, but not running the selection (if any).

    This is a really good idea! No, now it's not possible but I know what you mean: I could make it work in the following way: "run selection" will run the selection if any, otherwise it will default to "run current line".

    I am working right now on a pretty major release which would make possible, among others, to have remote sessions through ssh and to use other similar command-line driven software such as octave,  but given how busy I am it might take a while: sorry for the delay :(

    Best,
    Dan

     
    • mdowle
      mdowle
      2014-08-12

      Hi Dan,

      I still really like and use your plugin. Love the new features with remote sessions etc. And ... I've only just discovered you did this request from almost two years ago too! So the first item on the R menu is now "Run selection (or current line) through R ...". Perfect.

      I had a bit of trial-and-error redefining the hotkey but it's working great now. FYI, none of the following work (I was careful to restart gedit after each change) :

      Run current line: F8
      Run selection: F8
      ... Pressing F8 has no effect.

      Run current line: F5
      Run selection: F6
      ... F5 runs current line ok but pressing F6 puts focus to R and prints a tilde "~" there. Whether or not a block of code is highlighted. Clicking the editor window to make sure focus is on the code and pressing F6 again moves the focus to the R prompt and prints ~ again.

      Run current line: <Ctrl><Shift>R
      Run selection: F6
      ... same tilde problem as above

      However, the following three settings all work perfectly and appear to be equivalent; i.e. F5 runs what's selected, otherwise the current line if nothing is selected :

      Run current line: <Ctrl><Shift>R
      Run selection: F5

      or

      Run current line: F5
      Run selection: F5

      or

      Run current line: None
      Run selection: F5

      So at least for me, running gedit v3.8.3 and 0.8.0.2-Gtk3-Python3 Rgedit on a fresh and up to date install of Linux Mint Debian Edition, on a U.K. keyboard (fwiw), it needs to be F5 and not F6 or F8. I guess these are common keys other people might try so if a fix isn't straightforward maybe just adding some text to the top of the keyboard shortcuts window to warn about F6 and F8 would suffice.

      Could the label in the shortcuts window could be changed from "Run selection:" to "Run selection or current line:". One other label is on two lines already so it should fit. That wasn't clear to me for a while until I chanced upon the item in the R menu.

      Could F5 be the default since it works? Or F8 or F10 would be consistent with NppToR, S-PLUS and Matlab.

      Thanks,
      Matt

       
  • Anita
    Anita
    2012-10-04

    Hi all.
    I am trying to link rgedit to a manually installed R-version, so it does not use the preinstalled version which is old.
    Do anyone know where rgedit points to the R-files, and how I can change this link?
    Thanks.

    Anita

     
  • Dan Dediu
    Dan Dediu
    2012-10-05

    Hi Anita,

    right now, rgedit simply uses the "default" R (i.e., the one you get by typing "R" in a command prompt) and there's currently no easy way to change that within rgedit, which means that you have to somehow make your manually compiled R the default on your system (I guess that changing the PATH precedence should be enough).

    However, the new version of rgedit that I'm currently working on whill have a very general and user-friendly mechanism for specifying what program you want rgedit to use, not limited to another R version on your system but even other programs such as Octave and even remote R sessions through ssh. I hope to release it rather soon, depending on my free time…

    Best,
    Dan

     
  • Dryden
    Dryden
    2012-10-22

    Hey Dan,

    That remote connection through ssh that you mentioned would be a great idea. In the near future, I will probably use that frequently. Thanks for your continued support!

    Regards,
    Dryden

     
  • Dan Dediu
    Dan Dediu
    2013-10-29

    Hi Dryden,

    did you manage to use the remote session through SSH? Is it doing the job for you?

    Best,
    Dan

     
  • Dryden
    Dryden
    2013-11-30

    Hey Dan,
    Yes! It seems to work great. I ssh to my office computer from home frequently. You do have good timing with your reply though as I've got another question.

    I've never been able to actually terminate an R process in the R window that rgedit creates (ctr+c does not work). I can only terminate the entire session with ctr+z or simply close the window itself. It's never been a problem until now so I never bothered with figuring out how to fix the problem. But now, I want to use some R functions that require process termination (i.e. identify). Is there any other way to terminate a process? I run Lubuntu 12.04 and I fear that it may have something to do with my desktop environment (as no one else seems to post about this problem).

    As always, thank you very much for your continued support!

    Regards,
    Dryden

    Edit: It's not specific to rgedit. If I run R directly from the terminal I also can't terminate a process with ctr+c. I can use ctr+c for any normal processes in linux though...

     
    Last edit: Dryden 2013-12-01
<< < 1 2 (Page 2 of 2)