Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#2 second compiler exit

closed-fixed
Davy Durham
5
2002-08-16
2002-06-23
Markus Rechtien
No

Hi Davy,
after your changes everything seemed to work fine,
but then at the end this error appeared.
Thank you for your congratulations!!! :-)

----------------------------------------------------------------------
g++ -DHAVE_CONFIG_H -I. -I. -I../../config
-I../../src/misc -I../../src/misc/cc++
-I../../src/misc/missing/generated -I../../src/PoolFile
-I../../src/PoolFile/DiskTable -Wall -g -D_GNU_SOURCE
-Wno-unused-function -Wno-unused-variable -Wno-unused
-c ClibaudiofileSoundTranslator.cpp -MT
ClibaudiofileSoundTranslator.lo -MD -MP -MF
.deps/ClibaudiofileSoundTranslator.TPlo -o
ClibaudiofileSoundTranslator.o
ClibaudiofileSoundTranslator.cpp: In member function `void

ClibaudiofileSoundTranslator::loadSoundGivenSetup(std::basic_string<char,
std::char_traits<char>, std::allocator<char> >,
CSound*, _AFfilesetup*)
const':
ClibaudiofileSoundTranslator.cpp:177: choosing `type&
TAutoBuffer<type>::operator[](unsigned int) const
[with type = int]' over `
operator[]'
ClibaudiofileSoundTranslator.cpp:177: because worst
conversion for the former
is better than worst conversion for the latter
ClibaudiofileSoundTranslator.cpp:177: choosing `type&
TAutoBuffer<type>::operator[](unsigned int) const
[with type = int]' over `
operator[]'
ClibaudiofileSoundTranslator.cpp:177: because worst
conversion for the former
is better than worst conversion for the latter
ClibaudiofileSoundTranslator.cpp:179: choosing `type&
TAutoBuffer<type>::operator[](unsigned int) const
[with type = int]' over `
operator[]'
ClibaudiofileSoundTranslator.cpp:179: because worst
conversion for the former
is better than worst conversion for the latter
ClibaudiofileSoundTranslator.cpp:179: choosing `type&
TAutoBuffer<type>::operator[](unsigned int) const
[with type = int]' over `
operator[]'
ClibaudiofileSoundTranslator.cpp:179: because worst
conversion for the former
is better than worst conversion for the latter
make[3]: *** [ClibaudiofileSoundTranslator.lo] Fehler 1
make[3]: Verlassen des Verzeichnisses Verzeichnis
ť/src/ReZound-0.1.0alpha/src/backendŤ
make[2]: *** [all-recursive] Fehler 1
make[2]: Verlassen des Verzeichnisses Verzeichnis
ť/src/ReZound-0.1.0alpha/src/backendŤ
make[1]: *** [all-recursive] Fehler 1
make[1]: Verlassen des Verzeichnisses Verzeichnis
ť/src/ReZound-0.1.0alpha/srcŤ
make: *** [all-recursive] Fehler 1
ATHLON:/src/ReZound-0.1.0alpha #
----------------------------------------------------------------------

Discussion

    • assigned_to: nobody --> ddurham
     
  • Davy Durham
    Davy Durham
    2002-06-24

    Logged In: YES
    user_id=28588

    Hmm.. I my gcc (gcc (GCC) 3.1.1 (Mandrake Linux 8.3
    3.1.1-0.5mdk)) does seem to get that error...
    Could you tell me the output of `gcc --version` and I'll
    try to obtain that version and figure out what the problem
    is. I hope it's not a bug with the compiler that has been
    fixed or newly introduced...

    I don't know how familiar with C++ that you are, but the
    error doesn't make sense because it's saying it chose this
    operator[] definition over a different operator[] when there
    is only *one* operator[] definition in the TAutoBuffer
    template class! So I'll have to look more into it.

    Thanks,
    Davy

     
  • Davy Durham
    Davy Durham
    2002-06-24

    Logged In: YES
    user_id=28588

    FOLLOWUP: Okay.. I've compiled now with gcc 3.1 and gcc
    3.0.1 and neither show the error when compiling that file...
    So I hope you don't have either of those.. still looking
    into it.

     
  • Davy Durham
    Davy Durham
    2002-06-24

    • status: open --> closed
     
  • Logged In: YES
    user_id=567111

    Hi Davy,
    after i downgraded do GCC 2.95, ReZound compiled without any
    probs!
    then i tried to compile GCC 3.1 (again), which (now) worked
    fine.
    So at last i compiled Rezound again with GCC 3.1 (guess what?!)
    It didn't work again :(

    Another thing is a bug i discovered when i tried to reopen a
    .wav after i had closed it. You can see the response of
    ReZound on the attached image.
    Thanks for your help again!
    Regards, Markus

     
  •  
    Attachments
  • Davy Durham
    Davy Durham
    2002-06-25

    Logged In: YES
    user_id=28588

    This looks to be a bug in fox (The GUI toolkit). I will
    notify him of it.

    What I did was:
    file->open
    double click .wav file
    file->close
    file->open
    double click that same .wav file and it has the problem

    Then I noticed that the "File Name" field on the open dialog
    did not get set to the file I clicked on during the first
    click. To work around the problem, just click somewhere
    else, then back again on the filename (or use the
    file-reopen menu).

    I'll try to get them to fix this soon... Thanks, Davy

     
  • Davy Durham
    Davy Durham
    2002-06-25

    • status: closed --> open
     
  • Davy Durham
    Davy Durham
    2002-06-25

    Logged In: YES
    user_id=28588

    Okay, after looking at the problem a little more closely I
    have determinted that it is less a bug with FOX than it is
    just a side-effect to the way I was using FOX's
    FXFileDialog. So, I've fixed it in CVS now.

    Thanks!
    Davy

     
  • Davy Durham
    Davy Durham
    2002-06-25

    • status: open --> closed
     
  • Davy Durham
    Davy Durham
    2002-08-16

    • status: closed --> closed-fixed