Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#1 IBM DB2 UDB V6.1 - library libdb2ar.so

open
Mark Hessling
5
2002-03-30
2002-02-11
Anonymous
No

[root@ltest RexxSQL-2.4]# ./configure --with-orexx
--with-db2 --with-dbincdir=/usr/IBMdb2/V6.1/include
--with-dblibdir=/usr/IBMdb2/V6.1/lib --with-rexxtrans
loading cache ./config.cache
checking for one of the following C compilers: gcc cc
c89 acc... using /usr/bin/gcc
checking for gcc... (cached) gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a
cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking for POSIXized ISC... no
checking host system type... i586-pc-linux-gnu
checking target system type... i586-pc-linux-gnu
checking build system type... i586-pc-linux-gnu
checking for location of REXX header file... found in
/usr/include
checking for location of REXX library file... found in
/usr/lib
checking location of DB2 header and library files...
configure: error: libdb2ar.so or libdb2ar.a not found
in /usr/IBMdb2/V6.1/lib
[root@ltest RexxSQL-2.4]#

I can not locate libdb2ar.so in any of the IBM supplied
software. I have also checked the latest FixPack with
no success.
I have searched the IBM DB2 Web site with no success.

Thanks in advance,
Chris Lyons

Discussion

  • Logged In: NO

    The same problem with DB2 UDB 7.1 PDE on linux

     
  • Logged In: NO

    when compiling with DB2 UDB 7.1 PDE on linux, configure complains about libdb2ar (as stated above).
    libdb2ar can not be found in any db2 7.1 RPM (neither PDE nor EE).
    configure can be convinced to ignore the missing library. make then fails in cli-odbc/rexxcli.c because HWND
    is undeclared.
    Regards,
    Martin

     
  • Mark Hessling
    Mark Hessling
    2002-03-30

    Logged In: YES
    user_id=86185

    I've just done a search of the DB2 doco and found that the
    library that DB2 V7 uses is libdb2.so. libdb2ar.so was the
    library that was needed in V5 or V6.
    Could someone change the configure script to look for
    libdb2.so rather than libdb2ar.so (look for the
    string "db2ar") and post here how it went ?

     
  • Mark Hessling
    Mark Hessling
    2002-03-30

    • assigned_to: nobody --> rexx
     
  • Mark Hessling
    Mark Hessling
    2002-07-24

    Logged In: YES
    user_id=86185

    These problems should be resolved with the 2.4RC1 source
    released today, but I don't have DB2 installed to test them
    :-( . Please see the downloads page for the source ZIP
    distro.

     
  • Logged In: NO

    Version 2.4RC1 and DB2 UDB 7.1 PDE looks good on linux now.
    The simple-sample runs connects without problems.